SmarterMail V15 support question
Question asked by Jay Altemoos - January 7 at 1:28 PM
Answered
So I recently saw online under the online help for V15 "This documentation is for a product that is no longer supported by SmarterTools. ", so does this mean no future updates? Or is this a situation where if we have an active support plan for the year, we can still get patches as need be? I was kind of confused by the notification when i saw it today.

The reason I ask, our mail servers are Server 2008 R2 servers and as far as I am aware at the moment there's no plan for the immediate future to upgrade yet. I saw the system requirements for V16 and V17 needing to be on Windows 2012. So V16 & V17 are a no go for us. 

Can someone from ST please elaborate?

4 Replies

Reply to Thread
0
echoDreamz Replied
SmarterTools historically only supports the current and previous builds. So only 17 and 16 would be supported. They still may release updates, but pretty counterproductive to support a major build that is 2 versions behind.

Christopher

0
Matt Petty Replied
Employee Post
Just a heads up, the documentation says we support 2012 R2 and up. SmarterMail has the technical capability to run on 2008 R2 as well, as in the installer will let you install and it will run.

We are no longer actively fixing bugs in 15 and 16. There are still cases occasionally in tickets that we'll do a fix but these are generally tickets that came in before the release. I doubt we'll come out with any more updates minus a minor to cover the fixes that we've done in tickets and such. 
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Jay Altemoos Replied
Thank you for the clarification Matt. The question and concern I have now, how does this affect our licensing? We have a current support subscription until July of 2019 and we also have licensing for ActiveSync. 

When I checked the version information for the newest version ( I guess V17 or whatever the name of it is now), it mentions that you must have it installed on a Windows 2012 R2 server:

  • Windows Server 2012 R2 64-bit or higher - SmarterMail uses web sockets, which are not supported in IIS 7.5 or earlier.
  • Microsoft .NET 4.7 Framework
We have no immediate plans currently spec'd for a Server OS upgrade from 2008 R2 to 2012 R2 at the moment. So from what I am gathering from the OS requirements any newer version of SM is out of the question for us until a server upgrade is on the schedule.

So the concerns I have are as follows:

1. How does this affect our current licensing if we don't upgrade?
2. Barring any major issues, which at this point have calmed down, can we still submit a support ticket to get a resolution?
3. Subscription pricing, (and maybe this is something the needs to be discussed through email rather than on a forum post) do we continue with the support subscription even though we are not going to upgrade? And how does this affect our Active Sync licensing?

Let me know and if need be you could have someone reach out to me via email or phone to discuss.

Thank you.

1
Andrea Rogers Replied
Employee Post Marked As Answer
Hi Jay! 

I see that you started a live chat today and talked with Rose regarding your questions here... I'm going to add my reply anyway so you can see all your questions addressed together and so anyone else with the same questions can be helped. :) 

Benefits of having active Maintenance and Support:

  •  You'll have access to all new releases for the Current Build. (This is the next "major" release of SmarterMail, which is now numbered as 100.0.xxxx.) Releases will include new features, updates, bug fixes and other changes we make. Without Maintenance and Support, your license will continue to function, but it will no longer receive any version updates for new features or bug patches. 
  • Free technical support for standard issues! You can submit a ticket to the Support Department from the Technical Support page of our site and communicate with the support team via email or phone. Without Maintenance and Support, technical support will be limited to user-to-user interaction at the SmarterTools Community.
  • You'll be eligible to continue using Exchange ActiveSync and other add-ons. Our agreements with our add-on partners require that licenses be valid for the most recent public release in order to maintain compatibility with their products. Therefore, active Maintenance and Support is required to continue using add-ons or purchase them in the future.

To address your concerns: 

How does this affect our current licensing if we don't upgrade?
Licenses are backwards compatible which means you'll always be able to activate your license on the version it's valid for as well as any earlier version. Your license is valid for the Current Build, but you can continue using it on 15.x. 

Barring any major issues, which at this point have calmed down, can we still submit a support ticket to get a resolution?
You can! That's actually one of the changes we're most excited about. Free support has been requested for a long time and we were finally able to add it - without an increase in the licensing cost! (We actually ended up discounting the cost to reinstate an expired subscription.) 

There's only one thing I'd warn about regarding technical support for a legacy version: The Support team will work with you to determine the cause of an issue you're experiencing. They can answer technical questions and make configuration changes as needed. However, please note that hotfixes for bug reports will only be applied to the latest supported version. If your installation is running a legacy version, and the issue is determined to be caused by a bug in the software, you must update to the latest Current Build to access the bug fix.

Subscription pricing... do we continue with the support subscription even though we are not going to upgrade? And how does this affect our Active Sync licensing?
Our agreements with our add-on partners require that licenses be valid for the most recent public release in order to maintain compatibility with their products. (While you're not required to be on the latest version, you do have to be eligible to upgrade to it.) Therefore, active Maintenance and Support is required to continue using the add-ons. Your ActiveSync licensing would remain as it is today: Each year, you'll renew the 12 month subscriptions for Maintenance and Support (which is 60% off the retail cost of the license) and your ActiveSync subscription (which starts at $199 for 25 Mailboxes).


With the Maintenance and Support maintained on your license, when you're ready for the server upgrade, you'll be able to access the latest and great SmarterMail build available. 

For answers to additional questions, including "How do I know for which version my license is valid?", "What additional support options are available?", or "How do I extend/renew my Maintenance and Support?", please check out these articles that contain frequently asked questions: 

I hope this helps! Please let me know if you have any additional questions or concerns I can address.  

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

Reply to Thread