SmarterTrack 10.3.5416 problem with attaching file
Problem reported by Martin Chan - November 1, 2014 at 2:53 AM
Resolved
Does anyone have an issue attaching file after upgraded to 10.3.5416?
 

32 Replies

Reply to Thread
0
Bruce Barnes Replied
What browser are you running?
 
Some of our customer's have reported issues with various non IE browsers, but we're still checking them out.
 
You should also consider upgrading to 12.5, released last week.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Martin Chan Replied
12.5? This is smartertrack.
1
Bruce Barnes Replied
Should have been 10.3.5416, which was released on the 30th, so you are on the correct version.
 
I just verified that adding a file to a new ticket causes an error:
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
1
Martin Chan Replied
Have tried on 2 machines, both have exact same issue.
0
rene Replied
Same problem here, someone a solution for this?
0
Derek Curtis Replied
Employee Post
Double check the file types you're allowing for uploads. You can find this under:
 
Settings >> System Settings >> General Settings and clicking the Files tab.
 
Make sure nothing was reset or changed with any recent upgrades. This isn't a normal occurrence, but it's worth checking out. I hope that helps.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Bruce Barnes Replied
I'm uploading a .TXT file, which is clearly allowed in the files types:
 
 
Files can be uploaded on a NEW ticket, created by a user who opens a ticket via the tickets selection on the main SmarterTrack page:
 
 
 
 
but, if attempting to add a file to an existing ticket, after taking, when responding, the file upload fails.
 
 
 
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Derek Curtis Replied
Employee Post
Hmm..I just tried it on a brand new ticket and I could attach BOTH a .txt file and an .png.
 
Just for grins, Bruce, try removing .* for "allowed extensions using the HTML editor" and just leave the other file extensions. I wonder if the wildcard PLUS the other extensions is messing something up. Alternatively, you can simply change .* to just * as the period isn't necessary, but you'd want to remove the other extensions. Removing the wildcard entirely is a bit easier.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Bruce Barnes Replied
OK, removed the .* and changed it to just *
 
 
This removes the * comlpletely, and disallows the file upload:
 
 
 
Adding back *.*
 
again, the upload fails:
 
 
 
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Derek Curtis Replied
Employee Post
Okay. Well, I'm afraid I'm out of ideas. As I mentioned, I can upload both .txt and .png files when replying to a brand new ticket so something is odd, but it doesn't appear to be a bug in the installation itself. My only suggestion is to open a ticket so we can take a look at your database...
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Martin Chan Replied
Apparently, there are 3 person in this thread have exact same issue, so it's definitely not an isolated case. A fresh install was done and same issue occurred.
I suspect we are on IIs and Derek is using the default Smartertool web service.
 
Bruce,
Are you on IIs?
0
Derek Curtis Replied
Employee Post
We run on IIS as well with a SQL 2012 back end, just like any production environment.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Bruce Barnes Replied
IIS with MySQL
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Derek Curtis Replied
Employee Post
Martin, are you using MySQL as well?
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Martin Chan Replied
Hmm. IIs with SQL express.
0
rene Replied
We also run on IIS7 and MSSQL web edition.
0
Martin Chan Replied
Swap to smartertrack web server at 9666, same issue also
 
0
Martin Chan Replied
so must be something else we have in common that caused this issue.
Puzzled.
0
Tim Uzzanti Replied
Employee Post
Looks like we might need someone to open a ticket so that our team can look at a server and see what might be the underlying issue.  We can't reproduce this.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Ivan P Replied
Same issue here. Enteprise license. Please escalate the fix.
 
0
Derek Curtis Replied
Employee Post
Okay, we were finally able to replicate this. One of our Customer Service team members upgraded a local installation and was able to see the same behavior. Not sure why it's not occurring on our production installation, but regardless, we've escalated the issue to the developers.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Mike Kauspedas Replied
I'm here to report the same issue. I cannot attach in both FF and Chrome.
IE doesn't work either. 
1
Derek Curtis Replied
Employee Post
We've figured out the issue. A fix will be made available as soon as possible.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
EL-Support Replied
Same issue here!
0
Patrick Drudge Replied
What was the resolution to this? I have the same issue and am running Version 10.3.5416.18824
 
0
Steve Reid Replied
A fixed release will be out soon according to the post directly above yours
0
Patrick Drudge Replied
yes, I see that but thread is mark resolved... so that would lead me to believe it is resolved. not going to be resolved soon....
0
Steve Reid Replied
The thread is marked resolved for internal purposes. Meaning they have the fix completed in development. We will see it when they release the next minor, which we hope is coming shortly.
1
Andrea Rogers Replied
Employee Post
Hi everyone,
 
In reference to the reply and comments above me, Steve is right. This thread was marked as Resolved because we were able to resolve the issue internally; it just wasn't released yet.
 
The fix for this issue will be released in a minor version later today. Keep an eye on our News feed and social media pages to be alerted to when the release is available. 
 
Thanks!

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

2
Andrea Rogers Replied
Employee Post
SmarterTrack's minor release, 10.4.5423, is now available. Find the download link and release notes here: http://www.smartertools.com/smartertrack/help-desk-download.aspx
 
Thank you for your patience as we resolved this issue. Please keep us updated in this thread on the status of the attachment issue as you roll out this latest release.
 
Thanks!

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

2
Martin Chan Replied
Thanks Team. Problem solved.
0
Andrea Rogers Replied
Employee Post
Glad to hear that! Thanks for participating and bringing it to our attention.

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

Reply to Thread