Annoying "Browser notifications have been disabled for this browser" popup
Problem reported by Charles Michel - 8/31/2023 at 12:22 PM
It seems that the newer version of the smartermail webmail (at least Build 8629) are showing a yellow "Browser notifications have been disabled in this browser" popup when you login and the browser notifications are disabled. People who disable notifications do it on purpose to not be disturbed by popups, so it doesn't really make sense to nag this population with a popup telling them that they are missing out on more popups. It also seems that the acknowledgement of that popup must be stored in a cookie which gets cleared when the browser closes (at least the way my browser is set up), so I get the popup again every time I open the browser. 

Is there any way to disable this popup for the whole server? Or at least to store the acknowledgement server side so you don't bug the users every time?

3 Replies

Reply to Thread
echoDreamz Replied
Last I had read about this, Tim said they were going to fix this. I agree, it's annoying.

Kyle Kerst Replied
Employee Post
Hey Charles! As echoDreamz pointed out - we are working on improving this currently. In my latest internal tests these can now be dismissed as expected as we're storing that in the user cookie now.
Kyle Kerst
System/Network Administrator
SmarterTools Inc.
(877) 357-6278
Roger Replied
I also find this enormously annoying and there have been other posts here addressing exactly that. It should be adjustable to deactivate this generally, it disturbs in this constellation only

Reply to Thread