2
Build 8125 : unable to install
Problem reported by FrankyBoy - 3/31/2022 at 8:47 PM
Resolved
Hello everyone, I wanted to install the new buid (8125), but the installation suddenly stopped with an alert indicating that the installation contains a corrupt cab file. I then downloaded the installation file a second time, but nothing to do. I had to go back to the previous version. Has anyone been able to install it?

17 Replies

Reply to Thread
0
Sébastien Riccio Replied
Hello FrankyBoy,

I updated our server right now and the installation finished successfully.

Did you use the .exe or .msi version of the installer ? (I used the standard .exe installer)

Do you have windows defender active or any other antivirus on the server ? (we have windows defender completly removed from the system).

Maybe your antivirus catches a file in the installer as suspect.

Kind regards.
Sébastien Riccio
System & Network Admin

1
FrankyBoy Replied
Hello Sebastien,

Yes, I use the exe installer too and run it as Admin. I always uninstall previous version before upgrading and habitually all is working very well. Antivirus and Defender are desactivated during installation. Humm! Running on Win 2016 server.
1
FrankyBoy Replied
To be more precise in my explanations, here is a screenshot of the error message : 

When I reinstall the previous version, all is OK.
0
Sébastien Riccio Replied
Very strange indeed. I freshly downloaded the installer this morning and had no issue installing it.

I didn't uninstalled previous version though. Only stopped the service prior to starting the installer and let the installer do the previous version uninstall by itself.

It would maybe be interresting, while the installer is running, to copy that cab file somewhere else and try to open it.

It could also be a filesystem problem that is corrupting files... 
Sébastien Riccio
System & Network Admin

0
Gabriele Maoret - SERSIS Replied
Installed here in my test enviroment with no issues...

I first uninstalled previous version and then used the EXE installer.

0
Jay Dubb Replied
No trouble here.  Did you try uninstalling Smartermail, which does not disturb user data, then running the installer again?  (after downloading a fresh copy, of course)  Just double check to make sure you re-install to the same folder path.
 
0
FrankyBoy Replied
@Jay :  yes, as I usually do since 5 years!  It's the first time I have this error... 

I downloaded it 3 times. Completely uninstalled the previous version, rebooted the server, alwaays the same error. 

I even pushed the test by decompressing the problematic cab file with Winrar (when the error message appears) and Winrar decompresses it without problem. I confess that I am really starting to scratch my head!
0
Michael Replied
We were able to install just fine. As standard practice starting maybe 2 years ago we stop the Smarter Mail service before starting the updater. That seems to give better results.
0
Zach Sylvester Replied
Employee Post
Hello FrankyBoy, 

I wanted to reach out regarding this issue even though it's the weekend. 
There are a couple of things that I recommend trying. Firstly check to make sure that your server time is correct. 
Go to https://time.is on the server and make sure that is working as intended and is accurate up to the second. If that doesn't work please try going to that specified app data folder and removing that cab file. Then try running the installer again.  Please let us know if this helps. If not please open a ticket and we will get back to you within normal business hours. Have a great weekend guys. 

Kind Regards, 
Zach Sylvester
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Sébastien Riccio Replied
It could also be that for some reason your system can't authentify the signature of the .cab file.

Looking up your error message I found stuff like this:

It might also apply to the issue you're having.
Sébastien Riccio
System & Network Admin

1
FrankyBoy Replied
@Sebastien you're getting close to the solution for sure. The server is up to date and the time is properly adjusted. 

On the other hand, when I inspect the build 8125 installer, we see that there is something wrong with the certificate. See attached screenshots below. When I inspect the installers of previous versions, everything is perfect. I will continue to Google for solutions to try to see why I'm alone with this problem. If I,m not able to find any solution, I will open a ticket this night to see if Smartertools team have some solutions for me.




Thanks for your help!




0
Sébastien Riccio Replied
Marked As Resolution
Hello FrankyBoy,

Strange indeed. Here is a screenshot of what it says here about the certificate for that cab file.


Just for the fun I've compared both latest and a previous installer and the only difference in certificates I see is about the DigiCert Timestamp:


My guess is that there is something wrong on your rig about validating this one...

What OS version are you using for the server ?

Maybe something related to this:

Kind regards
Sébastien Riccio
System & Network Admin

1
FrankyBoy Replied
Hello (Salut) Sébastien ;-)

Thanks for your help. I will try different solutions proposed on the link you sent next midnight.

We run it on Win 2016 STD. All latest updates are applied.

We have a second server with the same OS, I will make a couple of tests on it.

Will come back here with a follow-up about my bug.

À plus! ;-)

0
Sébastien Riccio Replied
Salut FrankyBoy,

I am a bit curious if you were able to find the source of your installation issues ? :)

Kind regards.
Sébastien Riccio
System & Network Admin

1
FrankyBoy Replied
Hi Sebastien, I just finished to resolve my problem. The solution was too simple. I just manually re-imported «DigiCertTrustedRootG4.crt» on the server certificate store, and BOOM! The certification path of the Smartermail installer came back to normal. Just after it, I installed the new build flawlessly.

Thanks for your help, much appreciated.
0
Sébastien Riccio Replied
Hey FrankyBoy,

Great news. Thanks a lot to you for letting me know how you fixed it :)

Kind regards
Sébastien Riccio
System & Network Admin

0
Kyle Kerst Replied
Employee Post
I am curious how the DigiCertTrustedRootG4.crt certificate became invalidated in the first place. Perhaps one of the cross-verification certs was updated? Do you have a copy of the one that was failing validation?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread