3
Hide froala td/th borders within email preview pane
Problem reported by Dave Hunter - 8/1/2021 at 4:01 PM
Resolved
I thought I remember seeing this coming up in the past and later on a release note that it was fixed but I still notice borders around html td and th's within the preview pane but not in the stand alone email popup. Currently using Build 7879.


Below is the style that causes this  
.fr-view table td, .fr-view table th {
    border: 1px solid #DDD;
}

Could probably override by adding the ID of a parent container such as:
#messageViewFrameContainer .fr-view table td, #messageViewFrameContainer .fr-view table th {
    border: 0;
}

8 Replies

Reply to Thread
0
John Marx Replied
I would love to just have the ability for custom CSS. We could have an instant fix for items like this.
2
Sébastien Riccio Replied
I talked about this one in a different post (that I can't find anymore).

It seems that  Froala has different styles pre-defined for tables and the default is this thin outline but it can be changed in the editor while editing.


Still it would be much better if the default would be the style with no borders, especially for our customers pasting their signatures html as they often use tables to align stuff.

That's maybe something that can be setup via an option when loading the editor. I have very little to none at all knowledge about this editor...

Kind regards.
Sébastien Riccio
System & Network Admin

0
Dave Hunter Replied
Sebastien, that seems to be something entirely different and more so when you are editing. This is for all emails incoming while viewing in the preview pane. I even tried replying to one of these emails and setting the table to no borders but the original email still had borders around the td's. Still would be useful for the global css option as well since I could add the style I mentioned myself to resolve this. 
0
Andrew Barker Replied
Employee Post
Dave,

Could you send me a copy of one of the affected emails over PM? I would like to take a look at the email and see what is going on.

Andrew Barker
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

0
Sébastien Riccio Replied
Hello Dave,

Yes okay I've talked a bit too fast. I thought it was the same issue we have about the tables. My mistake :)
Sébastien Riccio
System & Network Admin

0
Andrew Barker Replied
Employee Post
Dave,

Using the message you provided me, I have been able to reproduce the issue you reported. It doesn't appear to be an immediate or persistent issue. In fact, it only appears to happen after previewing a message in the Drafts folder and then going back to the received message. After having viewed a message in the Drafts folder, the problem seems to persist until the page is refreshed, or until you have navigated to another section, such as Notes or Settings.

I have added this issue to our internal tracking system for revolution. In the meantime, refreshing the page and navigating to another section seem to be reliable workarounds.

Andrew Barker
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

0
Andrea Rogers Replied
Employee Post
Hi all, 

The issue with the table display in the preview pane has been resolved in our next SmarterMail release. That said, when forwarding or replying to an email with a table, the borders do appear in the compose window. We have another development task to look into our options for resolving the table formatting when forwarding or replying to the email. 

Thank you! 

Andrea Rogers
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
Dave Hunter Replied
Much love <3

Reply to Thread