Error setting up SmarterTrack from scratch
Problem reported by Wouter Luyten - November 27, 2017 at 6:13 AM
Submitted
Today I have downloaded the latest build of SmarterTrack to give it a try. I uploaded all files to the shared hosting, and then opened the url. I'm asked to enter database credentials. I choose a SQL server database with sql server authentication, entered all information and then went on to the next step. At this point I received an error message. After disabling the custom errors, I learned this is the error that is popping up:
 

Error parsing comment. Expected: *, got C. Path 'text', line 1, position 218.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: Newtonsoft.Json.JsonReaderException: Error parsing comment. Expected: *, got C. Path 'text', line 1, position 218.

Source Error: 

 
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 
 
[JsonReaderException: Error parsing comment. Expected: *, got C. Path 'text', line 1, position 218.]
   Newtonsoft.Json.JsonTextReader.ParseComment(Boolean setToken) +738
   Newtonsoft.Json.JsonTextReader.ParsePostValue() +275
   Newtonsoft.Json.JsonTextReader.Read() +129
   Newtonsoft.Json.Linq.JContainer.ReadContentFrom(JsonReader r, JsonLoadSettings settings) +858
   Newtonsoft.Json.Linq.JContainer.ReadTokenFrom(JsonReader reader, JsonLoadSettings options) +51
   Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings) +179
   Newtonsoft.Json.Linq.JObject.Parse(String json, JsonLoadSettings settings) +83
   SmarterTools.MasterPages.V5.Wizard.OnPreRender(EventArgs e) +458
   System.Web.UI.Control.PreRenderRecursiveInternal() +88
   System.Web.UI.Control.PreRenderRecursiveInternal() +160
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +985
 
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2116.0
 
I have also tried to use a MySQL database, but it is the same error that is occurring. Is this an issue with the current build?

5 Replies

Reply to Thread
0
James Jenkins Replied
Hey Wouter,

I'm confused with what you meant by "I choose a SQL server database with sql server authentication, ". Are you saying that you're using an existing SQL server database, or did you create a brand new one?
0
Wouter Luyten Replied
Hello James, I created a complete new SQL Server database (completely empty)
0
Wouter Luyten Replied
To make sure, I connected to the database using SQL Management Studio and the same credentials, and this is working like a charm. So the database is ok....
0
James Jenkins Replied
I never installed on a shared hosting service, so hopefully someone can share some light as to what's going on. As you said, you have access to the newly created SQL database, I could only ask if you verified the file permissions as per the the installation article

https://portal.smartertools.com/kb/a2574/installing-smartertrack-on-a-shared-server.aspx
0
Michael Woffenden Replied
Wouter, I agree with James. By definition, shared hosting environments tend to have more things locked down, since they are sharing a server with multiple clients. Since you don't have unfettered access to the server, you would need to work closely with someone at the shared hosting company to verify the requirements and permissions.

A fairly cost effective alternative (to shared hosting) would be to get a small AWS Windows virtual machine and host your web app and SQL Server database there. Then you would have full access to the machine and full control over the application.

Michael Woffenden, Founder and President, Information Results Corporation

SmarterTrack licensee since 2008

Reply to Thread