Smartertrack 12 and WHMCS
Problem reported by mi Pe - April 26, 2016 at 11:34 AM
Resolved
Hi,
 
It looks like after upgrading smartertrack to v12, the WHMCS module no longer works. The submitticket.php page just keeps loading. Can you confirm this, and is there an updated version available?
 
Thanks
 
mitch

3 Replies

Reply to Thread
0
when attempting to import users -> There was a problem calling SmarterTrack with this set of users. SoapFault exception: [Client] SOAP-ERROR: Encoding: string '\x8d...' is not a valid utf-8 string in smartertrack_functions.php:59 smartertrack_functionsphp(59): SoapClient->__soapCall('WhmcsEnsureUser...', Array) #1 \smartertrackphp(223): smartertrack_webServiceCall(localhos...', Array, 'WhmcsEnsureUser...') #2 smartertrackphp(192): smartertrack_functions_process_user_bundle(Array, Array, Array) #3 smartertrackphp(315): smartertrack_functions_importusers() #4 addonmodules.php(0): smartertrack_output(Array) #5 {main}

 
0
Hi,
 
We are upgrading to WHMCS 6.3.1 and having the same problem as described above. May I know Is there any solution released to resolve this problem?
 
Thank you
Jeremy
0
Andrea Rogers Replied
Employee Post
SmarterTrack and the WHMCS module have been updated to allow integrations between SmarterTrack and WHMCS 6 and 7. (More updates coming soon.)
 
Module 2.2, which was released in 2014 supports only SmarterTrack 10.5-12.2 when used with WHMCS 5. The recent updates allow SmarterTrack 12.3 to work with WHMCS 6 and 7, when using Module 3.0.
 
In short, Module 2.2 does not support WHMCS 6 or 7. In order to utilize the WHMCS 6 or 7, you must first update to SmarterTrack 12.3 and use Module 3.0.  
Andrea Rogers 
Communications Specialist 
SmarterTools Inc. 
(877) 357-6278 
www.smartertools.com

Reply to Thread