Problem with caldav
Problem reported by Jirka Schoell - September 14, 2014 at 8:57 AM
Submitted
Hello,
 
I run the latest version of the free edition on a Windows Server 2003/IIS6. All works fine, except caldav. It's really strange! I try to sync my Galaxy Tab 3 and a Lumia phone.
 
No problems with carddav! Both devices are syncing in both directions perfectly.
 
If I create an appointment on the devices I can see it with the Smartermail web interface. But if I create appointments with the web interface they will not synced!
 
I can see some 401 codes in the IIS logs while doing a PROPFIND method!
 
I spend hours to solve the problem. No success. I don't have any ideas.
 
Hope you can help me!
Greatings Jirka

4 Replies

Reply to Thread
0
Pete Hodgson Replied
I have a similar problem, except that my one-way-only sync is the other way: web interface propagates to devices & clients, but not from devices & clients (Android, and Thunderbird31 on Windows - both fail.). I've just posted my own thread about this.UPDATE: I've just re-tested this, and now it's working both ways. But it wasn't last night. Hmmm. Odd.

But now the Android sync via calDAV is completely broken. Grrrr.
0
Pete Hodgson Replied
OK, after re-establishing Accounts & Sync settings on Android, I'm up and running with 2-way sync... on TB31 AND Android!

Still no idea about why it was failing last night though.

BTW, my SM12 Free/Enterprise is running on Win7pro+IIS7
0
Jirka Schoell Replied
Is there really no solution for this problem?
0
Bruce Barnes Replied
CalDAV is an extension of WebDAV, and requires that the WebDAV be implemented in IIS:
 
"RFC 4791 is titled "Calendar Extensions to WebDAV (CalDAV)". It was designed as an extension, so implementing CalDAV sort of requires implementing WebDAV first... attempting to do it otherwise would be like attempting to implement HTTP without implementing TCP first"
 
To enable WebDAV in IIS 6, for Server 2003, requires that you enable the WebDAV IIS service extension in IIS.  This is done under the IIS service extensions in the IIS Services Manager.
 
 
This also requires that SmarterMail is running under IIS and that the internal SmarterMail webserver is disabled in services.  (As has been stated in the forums myriad times previously, the SmarterMail webserver is designed primarily to setup SmarterMail and not intended for production purposes.)
 
To learn how to setup your SmarterMail server to use Autodiscover for these services, see the article at:
 
The article goes into detail about additional setup to completely automate your services discovery for SmarterMail, and assumes that an SSL certificate has been properly installed and all of the required ports have been configured. 
 
Details on the configuration of SSL for SmarterMail can be found here: 
 
 
and details for configuring your ports can be found here: Configuring PORTS to use SSL / TLS to Secure SmarterMail - Version 8 and beyond
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting

Reply to Thread