Webmail - The page isn’t redirecting properly
Problem reported by Steve Gaston - 4/30/2024 at 6:56 AM
As per title, its occuring on only one of the Smartermail domains.

By what means can I troubleshoot this error?

Ι can access the domains webmail fine if I use the URL of the domain name that is used to host the smartermail software. i.e. https://mail.emailserver.com

But any request to https://webmail.clientdomain.com just give the message

"The page isn’t redirecting properly

An error occurred during a connection to webmail.clientdomain.com

This problem can sometimes be caused by disabling or refusing to accept cookies."

4 Replies

Reply to Thread
Steve Gaston Replied
Only way I can get the domain to come up is by stopping http://smwebmail.localhost/ on port 80 and assigning port 80 to the non functional domain.

Once i do that the non functional domain then reverts to https:// and loads correctly.

Looks to me that there is some information missing somewhere and this would have occured on the last update we made of Smartermail which im sure non coincidently resolved the server wide issue of http not resolving correctly to https.

Just this one domain got "left behind" ....
Steve Gaston Replied
Oh and there is no website hosting enabled for this domain, though I have other domains that are just email hosting that did not have this issue ...
Kyle Kerst Replied
Employee Post
Hi Steve! Sorry to hear you're having trouble with this! Based on your description above, it sounds like these two domain names might be setup on separate sites in IIS, is that correct? In that case the two sites are likely fighting over port 80 and so that's why you're finding only one will work at a time. To resolve that I recommend moving all of the SmarterMail-specific hostnames to a single site so that all of those bindings answer on the same site. This will allow IIS to decide whether port 80 is allowed or not based on the hostname users are requesting, and should prevent any conflict between the two. If you have separate public IP addresses available for those hostnames you can also configure those bindings to use that specific IP while you're in there. I hope that helps!
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
Steve Gaston Replied
Hi Kyle! 

Only one of the domain is "mine" the other domain is the local Smartermail domain that was created on first install of Smartermail and has always been there.

This is a recent issue that occured after upgrading to the latest Smartermail. I had previously posted here (that you responded to) that one of the earlier Smartermail updates had broken https redirection across all domains and I had to revert to the old https redirect method.

Then the latest updated (100.0.8853.23992) fixed the issue across all domain except the one that is currently having issues.

If you could point out to me how the redirect should work i.e what files/registry settings must I trace down to see why this one domain is not acting like the others.

Reply to Thread