CardDAV & CalDAV in eM Client Fail Build 8496
Problem reported by Scarab - 4/12/2023 at 2:30 PM
Users who were using eM Client configured with IMAP & CardDAV/CalDAV on previous versions of SmarterMail without issue had CardDAV/CalDAV go offline in eM Client after the upgrade from Build 8451 to 8496.

Their eM Client diagnostic log has the following:

11:55:56.452|00B|   Request:
12:00:56.403|018|   Method: PROPFIND, RequestUri: 'https://smartermail.scarabmedia.com/';, Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
12:00:56.403|018|   {
12:00:56.403|018|     Accept: text/xml
12:00:56.403|018|     Brief: t
12:00:56.403|018|     Depth: 1
12:00:56.403|018|     User-Agent: eMClient/9.2.1577.0
12:00:56.403|018|     Content-Type: text/xml; charset=utf-8
12:00:56.404|018|   }
12:00:56.404|018|   <?xml version="1.0" encoding="utf-8"?><D:propfind xmlns:D="DAV:"><D:prop><D:getetag /><D:displayname /><D:resourcetype /><D:sync-token /><supported-calendar-component-set xmlns="urn:ietf:params:xml:ns:caldav" /><supported-address-data xmlns="urn:ietf:params:xml:ns:carddav" /><xmpp-uri xmlns="http://calendarserver.org/ns/"; /><calendar-color xmlns="http://apple.com/ns/ical/"; /><D:supported-report-set /></D:prop></D:propfind>
12:00:56.404|018|   Response:
12:00:56.526|03D|   StatusCode: 405, ReasonPhrase: 'Method Not Allowed', Version: 1.1, Content: System.Net.Http.HttpConnectionResponseContent, Headers:
12:00:56.526|03D|   {
12:00:56.527|03D|     Alt-Svc: h3=":443"; ma=86400; persist=1
12:00:56.527|03D|     Date: Wed, 12 Apr 2023 19:00:56 GMT
12:00:56.527|03D|     Allow: GET, HEAD, OPTIONS, TRACE
12:00:56.527|03D|     Content-Type: text/html
12:00:56.527|03D|     Content-Length: 1293
12:00:56.527|03D|   }
12:00:56.527|03D|   <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">;
12:00:56.527|03D|   <html xmlns="http://www.w3.org/1999/xhtml">;
12:00:56.527|03D|   <head>
12:00:56.527|03D|   <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
12:00:56.527|03D|   <title>405 - HTTP verb used to access this page is not allowed.</title>
12:00:56.527|03D|   <style type="text/css">
12:00:56.527|03D|   <!--
12:00:56.527|03D|   body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
12:00:56.527|03D|   fieldset{padding:0 15px 10px 15px;} 
12:00:56.527|03D|   h1{font-size:2.4em;margin:0;color:#FFF;}
12:00:56.527|03D|   h2{font-size:1.7em;margin:0;color:#CC0000;} 
12:00:56.527|03D|   h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} 
12:00:56.527|03D|   #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
12:00:56.527|03D|   background-color:#555555;}
12:00:56.527|03D|   #content{margin:0 0 0 2%;position:relative;}
12:00:56.528|03D|   .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
12:00:56.528|03D|   -->
12:00:56.528|03D|   </style>
12:00:56.528|03D|   </head>
12:00:56.528|03D|   <body>
12:00:56.528|03D|   <div id="header"><h1>Server Error</h1></div>
12:00:56.528|03D|   <div id="content">
12:00:56.528|03D|    <div class="content-container"><fieldset>
12:00:56.528|03D|     <h2>405 - HTTP verb used to access this page is not allowed.</h2>
12:00:56.528|03D|     <h3>The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.</h3>
12:00:56.528|03D|    </fieldset></div>
12:00:56.528|03D|   </div>
12:00:56.528|03D|   </body>
12:00:56.528|03D|   </html>
12:00:56.528|03D|   AccountBase.ChangeOnlineState : State changed to OFFLINE due ConfigurationChanged
As a work-around we have them deleting the IMAP and CardDAV/CalDAV accounts in eM Client and re-adding the account, letting eM Client autodetect and autoconfigure for EWS.

A possible cause: We noticed that the SmarterMail server has WebDAV installed as a feature in IIS (probably has been for years). We have removed WebDAV and are pending a restart after-hours to determine if this resolves the PROPFIND rsp "405 method not allowed" error with Build 8496. Will update tomorrow if this resolves it.

2 Replies

Reply to Thread
Kyle Kerst Replied
Employee Post
I'm sorry to hear you're running into sync issues with WebDAV on eM Client. This involves an underlying issue in the eM Client, and they intend to release a fix in the near future. 

In the meantime though, I would encourage you to redo the connection in eM Client. eM Client now offers a combined IMAP, WebDAV, and XMPP connection for SmarterMail users and it'll be the best IMAP / WebDAV experience for them. Please see these steps: 

With that being said, you will want to leave the Windows WebDAV functionality disabled so that it doesn't override the SmarterMail DAV functionality. I hope that helps!
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
Scarab Replied

I can confirm that removing WebDAV Publishing Role didn't resolve the issue even after a system reboot, but I noticed that CalDAV & CardDAV in eM Client doesn't give a "405 Method Not Allowed" error to PROPFIND if you change the URI to include the path /webDAV at the end of the SmarterMail hostname (i.e. https://mail.mydomain.tld/webDAV). So, it simply looks like it is no longer being redirected to the correct resource properly from just the hostname and the URI for CalDAV and CardDAV now has to be set to manually include the path, just like you always had to do with Apple devices.

Good to know that an upcoming patch for eM Client is coming soon.

Reply to Thread