5
Outlook 2016, MAPI, and autodiscover failures
Problem reported by Mark Thornton - 1/4/2022 at 5:05 PM
Submitted
I am not having success with Outlook 2016 using MAPI to connect to SmarterMail. The problem seems to be the redirect on our apache webserver so Outlook will find the SmarterMail server. It keeps failing and drops back to ActiveSync. SM support says the redirect in apache is not passing the request for desktop (MAPI). 

I set up the redirect in cpanel on my webserver as seen below:

That created the lines below in the .htaccess file:
     RewriteCond %{HTTP_HOST} ^xxxfire\.com$
     RewriteRule ^autodiscover\/?(.*)$ "https\:\/\/mail\.xxxfire\.com\/autodiscover\/$1" [R=301,L]

Are any of you using apache on your website and have to do a redirect? If so, how did you put it in and make it work?

8 Replies

Reply to Thread
0
Mark Thornton Replied
I've tried changing from using the rewrite command to the redirect command in the .htaccess file with no change in behavior. 
Redirect "/autodiscover" "https://mail.xxxfire.com/autodiscover";
0
Mark Thornton Replied
I've now created a simple website on the mail server (new ip address) and set up the default.htm page to have the http redirect in the header. So any hit on xxxfire.com will be sent to www.xxxfire.com on my regular webserver.
<head>
<meta http-equiv="refresh" content="1; URL=https://www.xxxfire.com/"; />
</head>

I then created the IIS rewrite rule as described in https://portal.smartertools.com/kb/a2752/set-up-autodiscover-for-smartermail.aspx for the autodiscover function. 

You guessed it, that failed too. Outlook 2016 just keeps setting up using ActiveSync. I have followed the instructions on how to replace your MAPI account https://portal.smartertools.com/kb/a3487/how-to-thoroughly-replace-your-mapi-account.aspx with no change.

I'm sorry, but I just don't see how SmarterMail can be considered an Exchange replacement if it can't find a way to communicate successfully and reliably with Outlook. 



0
Kyle Kerst Replied
Employee Post
@Mark: As noted on the support ticket, MAPI synchronization is properly discovering and provisioning when tested off of this machine and other problematic machines. There is something specific to this client which is causing the client to receive an EAS response. When testing against MAPI accounts on this domain from our test clients here, the account setup completes successfully and without errors. Please see the last follow-up I have from development on this does shed some light on what is happening on this PC:

Per the Fiddler trace; The request has "Authorization: Bearer" in the desktop request, which we can't validate so we fail the response. However, we do tell it what auth methods we support (Negotiate, NTLM, Basic) but it never makes another request with a supported auth.

Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Mark Thornton Replied
I've moved to a new client laptop with a new install of Windows 10. From my windows login I can reliably attach to SM using MAPI on my personal email account, but if I try and connect with the one we have been working with it fails, repeatedly. Nothing is changing on the client side, just the entries in Outlook during setup. And yes, I am still doing the replace procedure between tests. I don't understand why one email address works and another doesn't unless it is getting something from the server to tell it to behave differently per the email address.

I have no problem if this is a client issue, I just need to know definitively. If I have to nuke all our clients so be it but it damn well better solve the problem or I will just be more frustrated. I am waiting on Office 2019 to arrive so I can see what it does.
0
Kyle Kerst Replied
Employee Post
I just wanted to recap my latest findings on this testing here as well so other users/administrators are aware of any details that might help track it down. I just connected to this account with your permission and was able to sync to it via Outlook without issue. This confirms there is something client-side preventing the discovery/connection, and causing those clients to receive EAS instead. Each account I've tested on this domain syncs right up without complaint. 

If there is anyone out there that can offer guidance on domain policies, protocol versions, even Windows updates that might apply - this would be a big help!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Mark Thornton Replied
So today I discovered I can get the problem email account to connect from Outlook 2016 via MAPI if I change the password. With a new password it works great. Set it back to old password and it fails. The behavior is repeatable, but I don't know why. The old password works fine with the web interface and ActiveSync mobile connection. My next step is to try the same on the desktop where the problem originated. I did remove the anti-virus on both the server and the client with no change, so it wasn't the problem. If I can get it working on the original desktop with a new password I will move on to other desktops and users with the same issue and see if a new password is the magic ticket.
0
Mark Thornton Replied
Overnight I tried an obscure registry entry PreferProvidedEmailInAutoDiscoverAuthPrompts for Outlook 2016, which failed with the old password. I also uninstalled Outlook 2016 and then installed Outlook 2019. It failed as well, even when I tried a manual setup that it offered. 
1
Manuel Martins Replied
Hi,
I have the same problem on some clients with Office 2016, if I try to create the MAPI account on Mail icon in Control Panel the process fails, but if i try to create the MAPI acount inside Outlook in File/Accounts it works fine.
Very strange...
Don't know if it's Outlook or Smartmail problem !??

Creating MAPI accounts in Outlook 2019 is working fine.

Reply to Thread