Couldn't Find CalDAV or CardDAV service
Problem reported by Jeff Mayfield - 10/18/2020 at 8:41 AM
Resolved
Trying to use WebDAV to synch calendar and contacts between SmarterMail Enterprise 7503 & Android 9 (Galaxy S8) using DAVx5.  DAVx5 pop up shows "Couldn't find CalDAV or CardDAV service" and it's debug info indicates there is a 404 error.  SmarterMail logs for WebDAV are empty.  IIS logs show 404.

Looking at the SmarterMail website on my server it looks like it is served from the MRS directory within the program directory.  I would expect to find a WebDAV directory or virtual directory somewhere, most likely in the SyncProtocols directory but I do not.  Note that my installation was upgraded from Pro to Enterprise if that might make a difference.

I do not have SSL.

I have tried the generic http://webmailhost.domain/WebDAV/ and the specific calDAV link from the calendar folder pop-up along in different case and with/without the trailing slash.

Am I missing something obvious like needing to enable a service in Windows, an IIS setting, a SmarterMail setting to enable the service?

6 Replies

Reply to Thread
0
Sébastien Riccio Replied
Hello,

On our setup the url, https://mail01.xxx.com/WebDAV/ prompts for user/password and then if I login with a mailbox creditentials, it returns "bad request". I guess it's correct because it needs probably to be a POST instead of a GET request.

Does it asks you for a password on your setup ?

Are you sure that in your IIS the port 80 for the hostname you're using is bound to the correct IIS virtual host (SmarterMail?).

Kind regards.
Sébastien Riccio
System & Network Admin

0
Jeff Mayfield Replied
Sébastien Riccio Thank you for your response.

If the behavior you describe is using a web browser my understanding is that a web browser doesn't know what to do with a WebDAV response.  I am using DAVx5 which should make the connection and synch the stock Android calendar and address book with SmarterMail.

I am certain the hostname is bound to the SmarterMail site as it works for webmail.
0
Douglas Foster Replied
I think the problem is your lack of encryption.   Install a commercial certificate, enable https, and try again.
1
FrankyBoy Replied
Hi Douglas,

Don't want to start de debate, but I'm curious : why a «commercial» certificate and not a Let'sEncrypt cert? Do you had any bad experience with it?

Regards,

Francis
0
Jeff Mayfield Replied
Marked As Resolution
Solved ... The Options and Propfind verbs were disabled server wide.  Turned those on and immediately connected.
1
Douglas Foster Replied
No objection to LetsEncrypt.    Just meant something that will pass certificate verification.

Reply to Thread