SmarterStats 11 stops processing logs for no apparent reason
Question asked by Smarty Pants - 5/7/2020 at 9:07 AM
Unanswered
Over the past 2-3 years, I've had to deal with a constant stream of issues with SmarterStats randomly failing to process logs for one or more of the sites setup in our installation - it would work for a month or two, then randomly stop for no apparent rhyme or reason. Nothing that I tried seemed to make any difference - the issues occurred whether I used logs stored in FTP, SFTP, local, or UNC folders (and changing between those for the effected sites made no difference).

So a few weeks back, I finally gave up on that installation & setup a new server with a fresh install of SmarerStats, in the hopes that the problems would no longer occur there - re-doing the setup completely from scratch (rather than migrating data to the new server, in the hopes of ensuring that there was no old data there causing issues.

Unfortunately, this seems to have made no difference whatsoever - and I'm still encountering the exact same problems on a fresh install of SmarterStats 11.3.6480 (on a Win7 Pro 64-bit VM). I haven't been able to try any newer builds, because unfortunately it appears that they fail to run on anything other than server versions of Windows. So even with only 6 sites setup in our install, it isn't working with 2/3rds of them (at LEAST), and only working intermittently with a third site. In detail:

  1. ALL SITES - logs processing lagging 2-3 days behind
    It's currently May 7th - yet even with the sites that are actually working in my SmarterStats install, none of them have logs imported past May 4th (3 days ago). That's despite the fact that they're ALL setup to process logs hourly - and there's no error messages (none that seem to be relevant to that issue, at least) or any other user feedback on why it's not working.

  2. Site ID: 2 - constant "Remote FTP Directory not found" errors
    This site is setup to process logs on a remote FTP server, and at least once per day SmarterStats gives me errors about being unable to find the remote FTP directory. I've checked multiple times & verified that the error message is not correct, however - the folder most definitely does exist when I manually connect via an FTP client. SmarterStats is also able to process logs for that site, which should be fundamentally impossible if the remote folder containing the logs didn't exist.

    The error is also inconsistent with what's shown in SmarterStats OWN logs - when I search the FTP logs for the same timestamp as the error, it shows it successfully connecting and downloading the log files from FTP. But then at the end of that operation, there's this error:

    11:55:21 access_log.webstat: Permission denied (code=550)

  3. SITE ID 3: only processed logs up to March 31st
    This site is also setup to process logs on a remote server (SFTP in this case), but SmarterStats has failed to import any logs past 3/31/2020. I've manually checked and verified that there are newer logs in the account, and the "Log Analysis" settings are set correctly that SmarterStats should pick them up - yet it doesn't.

    I've checked SmarterStats' FTP logs and it does show log files from April and May being downloaded - and I've checked the WebLogs_FTP sub-folder and verified that the folders are there. Despite that, SmarterStats can't seem to actually process/import them.

  4. SITE ID 6: fails to import ANY logs whatsoever
    Another site which SmarterStats fails to work with, in yet another way - in this one, it simply fails to import ANY logs/stats. The site is hosted on the same server as other sites that are working in this install, and it's setup the same way (process logs from SFTP, hourly, with "resume" and "Look for logs in .gz and .zip archives" enabled). Similar to the above issue, SmarterStats is downloading the log files from FTP, but failing to do anything with them beyond that.

    I even tried changing the log analysis settings to "Local Path" & configured it to use the path of the folder in WebLogs_FTP where SmarterStats had downloading the log files - but it fails to process those as well (with, of course, no error message or any other useful information to indicate why it's not working).

  5. Licensing/activation is hopeless mess
    I have no idea at this point if the license we own for SmarterStats is still valid for the version we're running, and/or if activated properly (because I'm getting conflicting/contradictory info on that from both SmarterStats itself & the account control panel on the SmarterTools website) - and/or if that's somehow related to the technical issues.

    The indications I'm seeing that the license is still valid & activated correctly:
    - SmarterStats accepted the license key when I activated it
    - In settings, the "Licensing" section hows the status as "Active License" and shows it as allowing for up to 50 sites (rather than the 1 site limit with the free version)
    - The software has allowed me to add/configure more than 1 one site after I activated it with our license (which it presumably shouldn't if the license were no loner valid)
    - Under "Licenses" in my account on SmarterTools.com, it's shown as activated & with the correct (new) server name

    On the other hand, the indications I'm seeing that it's not working:
    - In Settings > Licensing, in the "Feature" column, it's listed as "SmarterStats Free Edition," and not the license it should be ("SmarterStats Enterprise Edition" - confirmed via my account on SmarterTools.com).
    - When I run the "Self Diagnostic" under "Licensing, it shows "Failed" for "Product Activated?"
    - Under licenses on SmarterTools.com, the license is listed as "Expired Dec 6, 2013"

    I'd be willing to renew/upgrade the license if that would actually fix the problems I'm encountering - but I can't even find clear information on just whether or not the license is still valid, let ALONE whether or not that has anything to do with the problems I'm encountering. And I'll note posting here seems to be the only way to verify that, since it appears that you don't accept support tickets for an expired license - and the only other option seems to be using your paid emergency support service. Suffice it to say, I'm not really interest in paying almost as the software license itself, just for the "privilege" of finding out whether or not I need buy a new license from you.

It's reached the point where the issues we're running into with SmarterStats are making your software essentially unusable. Please advise as to the steps to correct those issues.

Reply to Thread