Beta, POP3 Message Removed
Problem reported by echoDreamz - 5/3/2020 at 2:53 PM
Resolved
We had this issue for a while, it disappeared, then came back today with 6 different customers reporting their POP3 client giving dozens of "Message Removed" emails. 2 of them are irate thinking they've lost mail and possible sales prospects, however, we cannot really tell them yes they have or no they havent. Most of the ones reporting this have never had this issue previously.

Seeing if anyone else has POP3 clients reporting this or are we just lucky?

20 Replies

Reply to Thread
0
Gabriele Maoret - SERSIS Replied
Hi Chris! Same issue here.

It seems to me that this problem reappeared with the installation of SM v. 7426.

I'm not completely sure, however, it could also be some previous versions.

Can you confirm? 
0
Gabriele Maoret - SERSIS Replied
UPDATE: it seems that going back to v.7425 the problem is solved.

Can anyone else confirm?
0
Gabriele Maoret - SERSIS Replied
I would add: it would be very important that the reason for these messages be clarified by SmarterTools.
0
Tim DeMeza Replied
We are also seeing this issue in the latest build as well.  I also, cannot confirm if they are real emails or not.  I am even wondering if they may be remnants of possible removed spam messages.  But the logs are not very helpful for finding this.  No info to search for really.
0
Robert Emmett Replied
Employee Post
Can we get the POP3 logs for day these messages are being observed and can we also have Chris, Gabriele, and Tim enable debug log id 20191227?  I will create tickets with the 3 of you to facilitate this.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Robert Emmett Replied
Employee Post
We have identified the issue and a fix will be included in the next build.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Good to know!
Robert, can you give us a meaning of that message? It's only a bug or  can it be received even in a working enviroment?

0
echoDreamz Replied
Can we get a link to this build? We need it badly, we have over 30 tickets open for this...
0
Tyler Raley Replied
Same issue here on Build 7426 (May 1, 2020).

-----Original Message-----
From: System Administrator [mailto:System Administrator]
Sent: Monday, May 04, 2020 12:03 PM
To: XXXXXX@XXXXXXXXXXXX.org
Subject: Message removed
This message is no longer on the server.
This message is a replacement for the missing message.










0
Thomas Lange Replied
Today I am planning to upgrade from build 7405 to 7426 (I am back from my two weeks vacation :-)
In case of custom build with a fix already available it would be great to receive the link.

We have around 25 useracocunts that can only use POP3 to download their emails including file-attachments.
I case of issues I think I have to 'downgrade" and use build 7425

0
echoDreamz Replied
Kyle told me they are doing a release today, so we will wait for the public release later today :)
4
Robert Emmett Replied
Employee Post
Everyone, the issue that came up is related to a change we made to fix some IMAP clients that would hang on updating folders. When a user removed ALL emails from a folder that folder's mailbox.cfg was also being deleted. This would normally be fine, but we noticed that some IMAP clients still expected the last known message UID and UIDVV both of which were contained in the mailbox.cfg.  Build 7426 changed the behavior of deleting the mailbox.cfg, but it was not updating the mailbox.cfg when ALL messages were removed from the folder--so it still that they were there even though the corresponding GRP files had been deleted.  For POP3 clients they typically removed all messages from the server in the Inbox.  The "Message remove" message is legitimate in that that message no longer exists on the server because the client had already deleted it, but the mailbox.cfg was erroneously reporting that it existed.

This has been fixed and will be available in the next release scheduled for this evening.  Chris, we are sending a custom build link to you now.  You can also wait until this evening's release, if you'd prefer. Thomas, I would hold off on upgrading until tonight public release.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Thomas Lange Replied
Thanks Robert, so I will wait until later this evening/night and check for next build with the fix.
I did not expect new build will be released today/tonight.
0
Gabriele Maoret - SERSIS Replied
Robert, many thanks for the comprehensive explanation. This is very important for us and also confirms that emails are not lost (in fact I already knew it because I checked a lot of accounts, but being sure of it is a real pleasure).

In any case, returning at the 7425 does not have a problem and with this you can safely wait for the new build.
0
echoDreamz Replied
This is still not fixed in the latest update. Users are still reporting receiving these messages. 
0
Tim DeMeza Replied
Again, same issue here.  People are getting really frustrated.
0
Gabriele Maoret - SERSIS Replied
Chris and Tim, are you using 7429? I don't have any report of this issue till now...
2
Robert Emmett Replied
Employee Post Marked As Resolution
I would like to reiterate that the issue that was introduced in SmarterMail in Build 7426 will ONLY affect those servers that were running that build. It was not present in 7425 and earlier and was fixed in Build 7429.  Those servers that had run Build 7426 may encounter reports of "Message missing", especially in POP3 clients, the next time they connect.

It's important to note that no messages have gone missing from the server, it's just a false error message being reported to the client.

Specifically, what was happening was this:

If a mailbox had all of its messages deleted (which is common with POP3), the mailbox.cfg was not being properly updated that all messages had been deleted. The next time a client application would request the message list for that folder, the mailbox.cfg would say it had messages available, even though the folder had been cleared.

When the client would attempt to retrieve these messages, they would not exist (because they had been previously deleted) and a "Message missing" message would be shown in its place. No new messages were being deleted, it was just a false error report.

This "Message missing" will happen per user for each folder that had ALL messages deleted while running on Friday's build. Once Build 7429 is installed this behavior is corrected, but the users will get that message, once per folder. This affected POP3 users the most since those clients are typically configured to remove all messages from the server once they have been downloaded.


Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
echoDreamz Replied
We are good so far, no further reports, but the dmg unfortunately was done for a few customers, we were able to keep them, but had to move them to our Linux systems :(.
0
Webio Replied
Hello,

If I've encountered this issue on build 7433 today should I report it? One of my clients have reported this behavior on todays message

Reply to Thread