[Beta, 7355] User reporting they cannot login, cannot impersonate either
Problem reported by echoDreamz - 2/22/2020 at 2:10 PM
Being Fixed
User says they get "logging you in" and that's it, when we try to impersonate, it just sits on the animated chaser/loading gif.

24 Replies

Reply to Thread
0
Sébastien Riccio Replied
We had such cases on the non-BETA release when 1) the user GRP files were corrupted, and also when 2) The user had a stuck active POP3 session that was keeping the GRP files locked.

For 1) I think there is an utility around to check grp files.
I don't know though if it's still compatible with mapi builds as they are changes in files...

For 2) Maybe you could check if a POP3 session is established for this user. Or simply do a domain reload which kills all sessions for the user.

Disclaimer: These are only suppositions, it might be totally another issue.
Sébastien Riccio
System & Network Admin

0
Robert Emmett Replied
Employee Post
Chris, if you have the browser console window open on the Network tab, what is the API call that is hanging?
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Matt Petty Replied
Employee Post
I would attempt to log into this user. If it continues, enable debug log id 111, then attempt a new login yourself to that user. If you see a spinner after login there is a chance this user is getting mail folders rebuilt. The 111 log should print some entries into it like "Starting rebuild for X".
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Shaun Peet Replied
We have a user reporting the same issue - they haven't received any mail since Friday (3 days ago).  They can send.  When I tried to impersonate I just get a spinning loading icon.

I noticed that this user had about 14 files in their MailProcessing folder which had datestamps from Friday as well.
0
Matt Petty Replied
Employee Post
Shaun could you do me a favor and enable debug log ids, 20191228 and 111, this is done in the sys admin Troubleshooting area. Once this is done, I would bounce the server then attempt a log into this user once it's back up. Wait a couple minutes then DM me snippets found in 20191228 and 111, in both those logs you can narrow it down using the user's email address.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
echoDreamz Replied
Another user reporting the same issue.

DevTools failed to parse SourceMap: https://REMOVED/interface/output/angular.js.map
DevTools failed to parse SourceMap: https://mREMOVED/interface/output/vendor.js.map
DevTools failed to parse SourceMap: https://REMOVED/interface/output/site.js.map
site-v-100.0.7355.28547.8d7b6577eaea800.js:100 SignalR Init2, Connected: undefined
site-v-100.0.7355.28547.8d7b6577eaea800.js:100 SignalR Start2
site-v-100.0.7355.28547.8d7b6577eaea800.js:100 SignalR Started2
site-v-100.0.7355.28547.8d7b6577eaea800.js:100 SignalR connection type: webSockets
Nothing odd in the console output. Checking logs. This client is saying that his email client is rejecting his password saying it is wrong, even though, it isnt. This user said the issue started Friday.
0
echoDreamz Replied
Checking 111 and 20191228 has nothing in them at all for the affected accounts.
0
Matt Petty Replied
Employee Post
Chris, can you check the network tab of the chrome debugger and check for any hanging or waiting web requests? (You can ignore httpbind if you see it)
You need to open the debugger first then login/navigate to the page.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
echoDreamz Replied
Nothing that I can see.

30 requests
1.2 MB transferred
5.3 MB resources
Finish: 1.66 s
DOMContentLoaded: 1.06 s

Everything appears to complete.

0
echoDreamz Replied
Also, same behavior as Shaun. Their MailProcessing folder has about 20 temp message files in it, though dated the 19th.
1
Shaun Peet Replied
We had 2 users where this was happening and we had to restore their mailboxes to get them working again.  It might be a longshot, but since both Chris and I had this issue and also had this issue here (https://portal.smartertools.com/community/a92941/beta-7355-sm-process-stalling-randomly-possibly-related-to-cyren.aspx ) I wonder if they are somehow related.  The reason I say that is because after repairing the two known users that had this issue, we haven't (yet) seen the SM process stall.  If that changes at some point then I'll update here.
0
echoDreamz Replied
Further weirdness, there is a crap ton of SMTP transactions to their address, but the SMTP transactions are all stopping after the RCTP TO: <xxxx> command and SM returns back RSP: 421 Command Timeout.
0
echoDreamz Replied
Shaun, I had DM'd Matt the same thing. I think us enabling Cyren was just bad timing, I believe this actually might be what is causing the stalling.
0
echoDreamz Replied

Is there a way we can get this utility, but only run it on a single domain instead of our entire server?
0
echoDreamz Replied
Running folder fixer on the 2 users did repair their mailboxes, though, the folder fixer is also "GetRidOfCustomFoldersFixer" too. Had to manually rebuild and add back all their folders. Now email received either since they reported the problem. The Lawyer firm that this happened to is going to be thrilled. Will report back if the stalling quits.
0
echoDreamz Replied
The tool did fix the issue with these 2 accounts, unfortunately though the law firm is reporting that adding the previously broken account to Mail Mail is not pulling down all folders, though the folders are listed in webmail. The firm owner has decided that this + losing 3/4 days worth of email correspondence, possible clients and other important emails is it and they are moving to O365 :(
1
Matt Petty Replied
Employee Post
After looking at the dump provided by Chris I saw a lot of threads waiting for mailbox initialization which happens upon login. Mailbox initialization happens to any mailbox not currently loaded into memory and things like deliveries, logins, cleanups, what not can all trigger an initialization. It appears the initialization it taking an exteremely long amount of time or is deadlocking on itself. I'm looking at newer logs provided by Chris and I may have a patch out in a bit based on what I find.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
echoDreamz Replied
Thanks Matt! Ill get you a DotTrace as well next time it stalls, which, based on our normal timeline should be around noonish.
0
Shaun Peet Replied
@echoDreamz - I guess I should have read more closely your comment about the utility being "GetRidOfCustomFoldersFixer" as i ran this on a bunch of domains last night and this morning we are getting bombarded with pissed off people.  Can you elaborate on the process you took to restore the folders to those mailboxes?  I'm going to have to do this about 100 times so hopefully there's a way to automate part of it.

SmarterTools - I don't understand why you have a utility in existence which aims to solve one problem by creating another, much bigger problem?  Please remove the FolderFixer.exe utility from the web or update it so that it doesn't wipe custom folders please!  This is going to create MANY HOURS of extra work for us after having run a utility provided by SmarterTools itself and nowhere does it mention the side-effects of the utility.  Planting the seed now that we should be getting a couple years of free maintenance because of this.
0
Sébastien Riccio Replied
Sorry it's a bit my fault to have talked about the FolderFixer tool. I used it successfully on pre-MAPI versions but never tried it yet on our MAPI beta environnement :/
Sébastien Riccio
System & Network Admin

2
Matt Petty Replied
Employee Post
Shaun there is a chance you can still recover the old folders.json files for each of your users in Archived Data. Depending on how many users you have this might be a labor intensive task unless you can get a script to do it. I'd test any file changes with a single user first before applying it to the whole system. I'm going to look into having this tool/post removed as it was not really intended for public consumption and is more of an internal tool we use in extreme cases. It came up to fix an issue we had a while ago with 17 (not beta), we have not tested it with MAPI.

On a more positive note, I believe we may have identified the stalling. I sent Chris a build last night and it's been running since without any stalling. We still need more time before we can say it's completely fixed but seems positive. Shaun I've sent you this build as well, anyone else is seeing this stalling can DM me and I can get you the build.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
echoDreamz Replied
We used the "rebuild folder" option in SM, added back each folder 1 by 1. If we did this on our entire server, it would be over lol. Thankfully, it was just 2 users with about 20 custom folders that had to be redone. Though, the 1 law firm is leaving after their macOS client wouldnt download some of the custom folders at all.
0
Shaun Peet Replied
Hi Matt,

So far the trick of grabbing the folders.json from yesterday's zip in a user's archived data and overwriting the live version seems to be working.  It's still labor intensive to do that for every mailbox, but it's less intensive than trying to attach the folders without really even knowing what they are to begin with.  Thanks for the suggestion.

I've also installed the custom build and hopefully that does its magic too.  To be honest, since "fixing" some of the known mailboxes that were having login issues (and wiping most of the custom folders in the process) seemed to have prevented the stalling from happening - although we're drowning in support calls about missing folders right now so it's hard to keep track of everything at the moment too.

Shaun

4
echoDreamz Replied
You can view the folders of each user on the file system directly, thankfully, we only had 2 users to do it for, so it wasnt a big deal.

SM really really really really really needs to be more resilient... I have no idea how these 2 users just go up in smoke, from working 1 second to completely dead and not receiving email. Maillist subscribers file going nuts and corrupting losing 10s of thousands of subscribers. What makes it worse, SM seems to always select the worst users possible to have these issues happen to, while we dont want any users having email issues, I'd rather it happen to bob's personal home email account with pictures of cats than one of the most well known Intellectual Property law firms in the world...

This is really hurting us as well as the image of SmarterMail. So many users have cancelled and moved on saying they cannot trust SmarterMail with their email any longer, we've been able to save a few and move to our Linux systems, but we are pushing SM as this big bad Exchange replacement, meanwhile, it's crashing, stalling, losing emails, corrupting users / files and numerous other big issues.

On the plus side of things though... Larry, Matt, Robert and Josh have been amazing. Working late, staying late, working over weekends and I am sure they hate us for making their lives miserable for the past few months. I appreciate their hard work and dedication and hope they are all getting big fat raises in the near future, I owe a lot of rounds and pizza to these guys.

Reply to Thread