[BETA 7314] Dissappearing folders with IMAP and Outlook for Mac
Problem reported by Alex Clarke - 1/13/2020 at 2:38 AM
Resolved
Since upgrading to the latest beta we've had a few users notice folders dissappear from their email clients.

The only thing in common is that all users are connecting with IMAP and using Outlook for Mac.

In all cases, the folders are available when accessing the mailboxes via webmail.

Anyone else notice this?

9 Replies

Reply to Thread
0
echoDreamz Replied
Yes, we have 1 open report of this happening as well. Between the custom build we received to fix the macOS Outlook crashing issue and this build, they reported no issues, however since installing this, we have 1 client reporting issues. I suspect as we get into the business day, we may get more.
0
Josh Pickering Replied
Employee Post
Have you noticed anything special or different about these mailboxes? are they shared? or does this seem to be a random mailbox?

I have added this to our bugs list, thank you.
Josh Pickering
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alex Clarke Replied
This seems random for our users.

The majority affected were using Outlook for Mac, but we did have a report from a client running Outlook 2007 that experience the same issue.

In the case of Outlook 2007, we were able to subscribe to the IMAP folders again and didn’t have to remove and then re-add the mailbox. 
0
Josh Pickering Replied
Employee Post
Hello,

I just wanted to clarify this a little bit more. You were not able to just subscribe to the folder in IMAP in Outlook for Mac and get the folders correct? Are they just not appearing in the subscribe list? Do you get an error, or does nothing happen?

Thank you in advance.
Josh Pickering
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alex Clarke Replied
Hi Josh,

I wasn't able to check the subscription to folders at the time.

However, I do recall that it wasn't possible to re-add the account after removing it.

I ran into the same problem I've posted about below.


After waiting several minutes, I gave up and added the account as EWS instead.

Cheers,

Alex
0
Josh Pickering Replied
Employee Post
Thank you for getting back to me with this.

We did replicate functionality that would look similar to losing folders over IMAP with shared folders and we have a fix going in for that soon here. If this issue pops back up and ends up being a different issue then that, please let me know. 
Josh Pickering
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alex Clarke Replied
Thanks for the update Josh.

The issue we experienced was with normal folders (not shared ones). Will your fix still resolve this?
0
Matt Petty Replied
Employee Post
Josh is out today, but I believe we applied this "auto-subscibe" fix to both shared folders and regular folders across the board. So it should fix both for you. If you still notice folders disappearing/not showing up update this thread and can check it out more.

EDIT: Existing folder properties/accounts connecting to IMAP may retain the non-subscribed setting for their folders. This may mean you need to resync. If this is a major issue we may be able to somehow auto-subscribe already un-subscribed folders.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alex Clarke Replied
Thanks for the update Matt.

I’ll keep an eye on this after the next upgrade and see if the issue persists. 

Reply to Thread