BETA 7269 unblocking an IP address doesn't unblock it
Problem reported by Robert Simpson - 12/2/2019 at 10:03 PM
Submitted
If I unblock a temporarily blocked IP address (due to password brute force rules) from the management tab, it doesn't unblock.  The system will continue to block it until I restart the smartermail service.  The logs show it being blocked, but it doesn't appear as a temporary block, nor does it show anywhere else in the UI.


3 Replies

Reply to Thread
0
Emily Ward Replied
Employee Post
Hi Robert,

Since you have active Maintenance and Support on your license I started a ticket with support for this.  I'll update the thread once they confirm it a bug.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Matt Petty Replied
Employee Post
I've been working with Robert and others in the Beta on the community directly. I apologize for not posting an update on this thread earlier...
I tested this through IMAP and SMTP and was able to get added onto IDS and remove myself off of it and connect without any issues.

My testing steps involved me using a client (em client) that allows me to specify different SMTP/IMAP credentials and for each one I put one good password and one bad password. I then tested my connection 5 times to cause one of the protocols to trigger. I then put in the correct password, attempted login, and was still successfully blocked. I then removed my entries from IDS then reattempted a login and it worked and I was accepted.

EDIT: Since 7269 is a beta-only build number, I added BETA to the thread title to reduce confusion with current SmarterMail versions.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Robert Simpson Replied
I'll try and get my system into this state again, it's happened a few times so far.

Reply to Thread