Trying to make SmarterTrack PCI Compliant. Getting an Error.
Question asked by Steven Pink - May 13 at 3:58 PM
Answered
I'm glad SmarterTrack was upgraded to JQuery 3, because that kept failing my PCI monthly compliant scan but now getting one more thing with SignalR which is using JQuery 1.6, is there a way to make SignalR use JQuery 3? 

I am getting the following error.

matched "..\\..\\SignalR.Client.JS\\Scripts\\jquery-1.6.4.js -> /support/signalr/hubs"

Thanks.

4 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Steven,

I believe changing the JQuery version being used would likely require code changes on our end. I can check with our development team on this though, and I'll reach out to update you when I have more information.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Kyle Kerst Replied
Employee Post Marked As Answer
Steven, I was able to confirm with development that our current implementation of SignalR CAN be upgraded to the newest release (which includes JQuery 3) and so we're going to add a feature request now to have this addressed in the future. Unfortunately though it may be some time before this gets looked at as it may require significant research and testing for proper implementation as there are some components no longer available in the latest SignalR releases that we may leverage in SmarterTrack. So this may not happen quickly, but it is on the list! Hope this helps Steven. Have a great rest of your week!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Steven Pink Replied
I understand, thank you for your response. You have a great week too.
1
Kyle Kerst Replied
Employee Post
You're very welcome Steven. Happy to help!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread