Cannot edit outgoing gateway
Problem reported by echoDreamz - January 21 at 12:08 AM
Resolved
The save button never enables itself after making changes. There is also a warning that says no domains are assigned to it, however it is a "Round Robin" outgoing gateway, so... yes, there are no domains assigned to it since all domains use it.

SM 17 6956

Christopher

8 Replies

Reply to Thread
0
Andrea Rogers Replied
Employee Post
Hi Christopher, 

I see the domain warning when my gateway is set to Round Robin. However, I'm not able to replicate an issue with the Save button. What change did you make to the gateway? Do you perhaps have an invalid fields that need to be fixed first? (You can find out by placing your cursor in the Server Address field and tabbing through all fields on the page. If any inputs are invalid, this will force the red validation error to appear.)

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
echoDreamz Replied
Ah, yes, the "Enable SmarterMail Gateway Mode" => "SmarterMail URL" option says that https://xxxxxx is not a valid domain name, even though it's asking for a URL, not a domain name, if I remove the https:// prefix it works fine, but this now means that SM is communicating with the gateway without HTTPS.

Christopher

0
Luk Replied
Hi,
I have similar problem on incoming gateway configuration (SM 17), I cannot edit gateway until change “Smartermail URL” to something like "mydomain.com" so I cannot use HTTPS for Smartermail URL. Also, in delivery logs there’s no Spam check results so I cannot tell whether spam check works.


0
Webio Replied
I've reported URL field as an addition to my incoming gateway issue here:


EDIT: I'm wondering are you using incoming gateways as a Domain Forward?
0
echoDreamz Replied
Yeah, it doesnt accept "http" prefix at all, only a hostname without the protocol.

Christopher

0
Luk Replied
Webio, I'm using incoming gateways as a Domain Forward.
Can you check your delivery logs for spam check results?
0
Webio Replied
Are you using v17 incoming gateway with Domain Forward, disabled SmarterMail Gateway mode and enabled SMTP Verification? I've made some tests today (I've upgraded again one of my v16 incoming gateways, disabled smartermail gateway mode, enabled SMTP Verification, Domain set to All Domains except where I added one random domain - IMHO there should be third option All Domains - and in this configuration no checks are being made.
0
echoDreamz Replied
Marked As Resolution
ST has confirmed this will be fixed in the next minor release.

Christopher

Reply to Thread