Primary admin email account deleted
Question asked by Tony - November 8 at 5:10 PM
Unanswered
For the past 2 weeks, we have email users reporting they can't login to their primary admin email account for their domain. When we checked, we found the primary admin email account were removed. In some case, we see a non existing user "Empty" from the drop down menu when we click on Edit on the domain which had the issue within the Smartermail admin panel. 

For those cases, we did notice the primary admin email account deleted regular email account according to the Smartermail admin log. So at first, we thought the issue may be related to user deletion within the Smartermail user admin panel. We tried to replicate the issue, but was not able to. We created user with admin privilege (Enable domain administrator access) , and tried to delete the primary admin email account with the newly created email account, and it didn't work at all. Just wondering if anyone else had experience or seen the same issue or not.

We are running SmarterMail Version - 15.7.6821. Thanks.

3 Replies

Reply to Thread
0
Robert Emmett Replied
Employee Post
Tony, I am sorry to hear that you are experiencing difficulties with primary admin accounts.  Are you using the web interface or a control panel like WHMCS or Plesk?  Have you verified that the actual primary domain admin accounts are missing from the physical file system?  Look in the C:\SmarterMail\Domains\{your_domain}\Users\{primary domain account} folder.  Does that folder exist?  If so, does a userConfig.xml exist within that folder?
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Tony Replied
Hi Robert,

Thanks for the reply. We are managing through the web interface. The Smartermail is installed on Windows server. We did check the domain data folder to see if the primary admin user folder exist or not, but it was not there when we checked. We have backup running daily, so restore was not an issue. We will keep an eye on the issue for now.
0
Tony Replied
We had another case from client today.

I have provided the sequence of the event from our investigation.

1. Client login primary admin email account "primaryadminuser" at 07:22:32
2. Client change password and setting for user "userone" at 07:29:06
3. Log shows user "userone" was deleted by primary admin user at 07:31:43. The user "userone" is still on server but not the primary admin user "primaryadminuser".
4. On server maildata folder, and the accountlist.xml file last update stamp was 07:32, primary admin user "primaryadminuser" was not in there
5. On server maildata folder, the Users folder last update stamp was 07:32, primary admin user "primaryadminuser" folder was not in there

===administrative log between client===
[2018.11.18] 07:22:32 [client IP] [qyedhu]  Login was successful for user: primaryadminuser@sampledomain.com   ROLE: Domain Admin
[2018.11.18] 07:29:06 [client IP] [qyedhu]  Password was changed for user'userone@sampledomain.com' by 'primaryadminuser@sampledomain.com'
[2018.11.18] 07:29:06 [client IP] [qyedhu]  User 'userone@sampledomain.com' settings changed on domain 'sampledomain.com' by 'primaryadminuser@sampledomain.com'
[2018.11.18] 07:31:43 [client IP] [qyedhu]  User 'userone@sampledomain.com' deleted on domain 'sampledomain.com' by 'primaryadminuser@sampledomain.com'
[2018.11.18] 07:34:25 [client IP] [qyedhu]  'primaryadminuser@sampledomain.com' logged out
[2018.11.18] 07:39:25 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
[2018.11.18] 07:39:41 [client IP] [qyedhu]  Attempting to login user: userone@sampledomain.com
[2018.11.18] 07:42:33 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
[2018.11.18] 07:44:15 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
[2018.11.18] 07:44:20 [client IP] [qyedhu]  Attempting to login user: userone@sampledomain.com
[2018.11.18] 07:45:13 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
[2018.11.18] 07:46:10 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
[2018.11.18] 07:46:32 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
[2018.11.18] 07:46:37 [client IP] [qyedhu]  Attempting to login user: userone@sampledomain.com
[2018.11.18] 07:54:12 [client IP] [qyedhu]  Attempting to login user: primaryadminuser@sampledomain.com
======

Reply to Thread