SM 15.7.6572 DKIM 100% inbound failures...
Problem reported by Joe Wolf - January 24 at 10:29 AM
Resolved
Since upgrading to 15.7.6572 we've had to kill inbound DKIM spam testing due to 100% failure rate.  The Delivery Log shows the following for every message:
 
DKIM Fail: The DKIM key has expired as of 1/1/0001 12:00:00 AM
 
All show the date and time as 1/1/0001 12:00:00 AM
 
Since the date is illogical I suspect a program bug.
 
-Joe
 

9 Replies

Reply to Thread
0
Robert Emmett Replied
Employee Post
Joe, this issue has been resolved and will be available in the next maintenance release. If you would like a prerelease build of it is available here:
 
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Joe Wolf Replied
Robert,
Thank you!

-Joe
0
echoDreamz Replied
Robert - We see this in SM 16 as well, will it be fixed too?

Christopher

0
echoDreamz Replied
Scratch that, dont seen anything in the last few weeks, a previous update must have fixed it.

Christopher

0
Hemen Shah Replied
Observed the same in the logs post raised by Joe,
Prerelease build above is final to use or any change expected in the same ?
0
Joe Wolf Replied
The above listed release solved the problem for me and the system is running stable.

-Joe
0
Hemen Shah Replied
Can this issue result in outgoing mails from SM land in receipient junk/spam box ?
i am yet to apply latest update but post last update am getting lost of users complaining about outgoing mails landing in recipient junk box
0
Joe Wolf Replied
Hemen, I don't think this issue had anything to do with outbound DKIM, but I think there was a different problem if you recently tried to generate new DKIM signatures. I think that was resolved in the most recent release.

-Joe
2
kevind Replied
Still seeing problems with DKIM using latest release (15.7.6600) on gateway.
 
100% failure on messages that come in from backup MX gateway. Also fails Reverse DNS check which is odd.

Reply to Thread