Agent Role Cannot See General Queue Anymore ST13
Problem reported by Jonathan Garber - December 7, 2017 at 10:25 AM
Not A Problem
Before upgrading to ST13 our Agents (Agent Role) could see the general queue and pick/pull tickets to work on. This is no longer the case in ST13. I have found the only way to let them see the queue now is to assign them the Manager Role.
 
Any chance of patching this so Agents can go back to seeing the general ticket queue?

2 Replies

Reply to Thread
0
Eric McCarthy Replied
Employee Post
Go to settings/departments and select the department that you want everyone to be able to pull from and check the setting "Allow all agents to see the contents of this department." Doing this will allow your agents to see tickets in the queue for that department, even if they are not members of it. If you have this option unchecked, only members of the department can see its items in the queue.
Eric McCarthy
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Jonathan Garber Replied
That setting is already checked as it was set before upgrading to 13.
As I said previously "Before upgrading to ST13 our Agents (Agent Role) could see the general queue and pick/pull tickets to work on."

All of our "Agent" roles could no longer see the general queue after the upgrade. They went right back to work in ST right after the upgrade was done. I got calls from several people who could no longer see the general queue and I verified it myself with an agent account. Now since I had some free time today, I went testing some things and here is what I found.

If I take a user who is in "Agent" and was "Agent" before the upgrade, I logon as that user. I cannot see the general queue. If I add the "Manager" role to that user I can then see the general queue. Now if I go back to that user and remove the "Manager" role that user can now see the general queue while just under the "Agent" role. I suspect during the upgrade some piece of data for those permissions wasn't registered or was lost and saving roles again may have fixed it.

So for some reason I had to adjust their roles once then I could go back to their normal role and the general queue worked/showed as expected. So that seems to resolve the issue. I never tried that until today.

Reply to Thread