Install New Smartermail 16
Problem reported by svr - November 12, 2017 at 9:26 AM
Submitted
I am familiar with Smartermail for many, many years since the days at CrystalTech, Derek Curtis if my memory is right. The product seems to get worse and buggier with every new release/ update. Example:
 
Smartermail lost constantly the HostNames assigned in Bindings to 3 different dedicated IPs.
Downloaded and installed the latest upgrade (November 9) as suggested.
Opened Smartermail and one domain was missing the admin account. Recreated and saved it.
Closed Smartermail, and checked "mailConfig.xml" and everything looked fine.
Opened "Smartermail - Logs" and the "Load" log stated that the 3rd domain cannot be loaded and this is a process to prevent data loss.
Started Smartermail and deleted the domain in question.
Closed and reopened Smartermail and added the domain deleted previously.
Same problem as before in: Load Log ...
Uninstalled Smartermail and made sure everything is removed.
Deleted manually folders in Program Files (x86), deleted C:\Smartermail
Went through the entire registry manually and removed all keys/ entries related to Smartertools and Smartermails.
Stopped IIS, removed everything related to Smartermail and restarted IIS (8.5 on Windows 2012 R2)
Installed Smartermail and everything ran as expected including creation of new IIS localhost account.
Page opened asking to create an Admin Account.
When clicking Next" produces error message like: "Error when trying to create primary admin account."
Repeated everything again: Uninstall, remove delete, registry clean, etc.
Cannot get into Smartermail, tried with and without License Key.
Smartermail is not allowing or unable to create the primary admin account.
Installed hMailServer because I need continued e-mail service and I am extremely frustrated!!!
 
Was the latest release tested and validated? The update converted a functional application into something that is absolutely useless at the moment.
 

12 Replies

Reply to Thread
4
Stefan Mössner Replied

I can confirm that the newest release of SmarterMail 16 doesn't work. I can't login to the system, see https://portal.smartertools.com/community/a89867/smartermail-16_3_6522-cant-be-accessed.aspx.

I think you're right that the product is getting worse and buggier with every new release but only since major release 16. There are a lot of issues with some absolute basic functions. Until 15.x I didn't had so many issues with this software. I'm using SmarterMail now for 7 years. In the past for me there was no need to have a test environment. With 16.x it's highly recommended.

And since some minor releases it isn't possible to answer the new release announcements in this community. SmarterTools seems not wanting to know which issues we have. And there are no answers from SmarterTools to issues which aren't solved for a long while!

There are two possibilities: Stay with SmarterMail 15.x or search for an alternative. I will stay with 15.x for  the next time. But if SmarterTools won't change their policy regarding solving the issues and answering the threads in their community I will have a look for alternatives.

1
Lennart Eliasson Replied
I have exactly the same problem. New install on windows 2016 server. The installation went ok.
But the problem is: 'error creating the primary administrator account'
 
 
2
svr Replied
Spent hours to figure out what the problem is and finally started again from scratch with V15, then V16 previous release and then the Nov 9 release of V16. It seemed to apply the update without issue and I was able to start Smartermail. Looked good, added additional users and then checked "Bindings": All HostNames assigned to dedicated IPs were gone. It listed the descriptions but that's all and this is what started the initial problem. Will go back to V15 and explore other server software. SmarterTools is not as reliable and trust-worthy as they used to be. My biggest complaint: They know that there is a big problems with the current version but they still offer it for download and there might be many customers like me ending up with no e-mail service at all for several hours.
0
Derek Curtis Replied
Employee Post
I apologize for not seeing this thread earlier. The last minor release did have an issue with new installs. This has been corrected and the version available for download from our site has the fix. So please use that new download for a new, fresh installation. 
 
The hostnames issue is something new. I'll look into that. 
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Derek Curtis Replied
Employee Post
This is definitely a unique issue. We run multiple domains on our SmarterMail servers and update it constantly, but we've never run into an issue where the hostnames disappear...Just to make sure, if you edit the binding, the hostname is gone there as well? So it's not simply a display issue on the main bindings page?

I may have one of our support reps reach out to you on this as this is the first I'm hearing of this particular issue.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Derek Curtis Replied
Employee Post
Regarding Announcements, those thread types aren't there for compiling a list of bugs. That's why they're locked. Having separate threads for bugs allows us to focus issue-by-issue and, in many cases, start tickets from Threads based on issues people are seeing. Many times, the bugs reported are only seen by a few people while others may be more wide-ranging. In addition, the Announcement threads were getting so long that things were being missed. That's another benefit of having individual threads for individual issues.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Derek Curtis Replied
Employee Post
Lennart, try the new download available from our site. There was an issue with new installs that has since been resolved and released.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
svr Replied
In regard to not being able to install SM V16 because administrator account cannot be created:
A mail server is a very important software application because it not only submits and transfers personal and confidential data, it also could more or less cause financial issues for a business if black-listed and i.e. interested buyers never receive a price quote. No price quote - no response - no purchase. 
 
I therefore assume that your company follows Life Cycle Development Procedures and I am wondering what your test results were when you tested and installed the app/ upgrade prior to release and what your release specifications in regard to IQ and OQ are? Didn't you experience any problems? Just curious!
0
Trevor Spink Replied
I am getting the same problem with a fresh install today.
 
I cannot create an administrator account
0
Trevor Spink Replied
Still getting this issue as of today with a new install from your site.
0
Derek Curtis Replied
Employee Post
Hi, Trevor. This is the first issue we've had for some time relating to creating of an Admin account. My initial advice would be do completely uninstall SmarterMail -- including deleting all folders after running the uninstall -- and trying again. I'll do another test install here locally and see if I can reproduce the issue.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278
0
Derek Curtis Replied
Employee Post
I just tried this twice: once using the IIS Configuration tool and once manually setting up an app pool and website in IIS. Both attempts were successful: I could create my admin account no problem. This was on a Windows Server 2012 R2 VM, FWIW.
Derek Curtis
COO
SmarterTools Inc.
(877) 357-6278

Reply to Thread