new issue popped up after reinstall of V15 from V16 smartermail
Problem reported by Michael Luer - December 17, 2016 at 4:59 PM
Submitted
I wanted to do the beta so I loaded it up. looked great but didn't have advanced spam filter cyren enabled so I uninstalled and reinstalled version 15.  I had to reestablish my iis webmail delivery but it seemed to be just fine.   However I get this message when I log in as administrator.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The error log showed this:
 

[12/17/2016 3:45:43 PM]

System.NullReferenceException: Object reference not set to an instance of an object.
   at SmarterTools.HyperControls.HGCheckBoxColumn.IsSelected(Object dataItem, Int32 rowNum)
   at SmarterTools.HyperControls.HyperGrid.#TO(Object #OC, Int32 #EKi)
   at SmarterTools.HyperControls.HyperGrid.PerformDataBinding(IEnumerable retrievedData)
   at SmarterTools.HyperControls.HyperGrid.#KO(IEnumerable #FKi)
   at SmarterTools.HyperControls.HyperGrid.PerformSelect()
   at SmarterTools.HyperControls.HyperGrid.DataBind()
   at SMWeb.Main.Alerts.frmAlertPopup.GenerateGridSystem()
   at SMWeb.Main.Alerts.frmAlertPopup.GenerateGrids()
   at SMWeb.Main.Alerts.frmAlertPopup.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at SMWeb.HelperClasses.CustomPage.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
Application Error

 
Any thoughts I figured it would fix itself when spammers tried to hit the box but no dice.
 
Cant wait for Version 16 but I need to test with Advanced Spam filter or just wait till I can upgrade completely fully licensed
 

2 Replies

Reply to Thread
0
Bruce Barnes Replied
Did you do a complete backup of 15, as mandated in the beta instructions?

Did you uninstall 16, reboot, and then reinstall 15?

Did you check your IIS settings? The SmarterMail IIS is intended for setup only, and not for general use, and should be disabled in Windows Services.
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Michael Luer Replied
yes always uninstall and reboot before install of any new version. the smartermail webserver is disabled and turned off just a real iis instance running now. but I had to create a new real iis instance to host webmail after it not recognizing the reinstall of version 15. once I recreated a new iis instance and pointed it to the webmail folders it worked with only this one thing popping up now every time I log into administrator. btw on another note I was thinking about adding message sniffer. how well does that addon work?

Thanks,

Mike

Reply to Thread