Edit Contact - 2 buttons don't work
Problem reported by kevind - August 29, 2016 at 7:13 AM
Submitted
  1. In webmail, go to Contacts and select a contact.
  2. Click the Edit button which opens a new window.
  3. The Download and Delete buttons at the top don't do anything.
Using IE, Edge, & Chrome on SM 15.2. Didn't see a fix in 15.3.
 
Suggestion: these buttons aren't needed in Edit because you can Delete & Download on the main screen. However, an Cancel button would be nice in case you want to abort your editing.

6 Replies

Reply to Thread
1
Matt Petty Replied
Employee Post
I fixed the delete issue. The download button is not working still, I'm wondering if this has to do with it being in a lightweight browser window.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
Thanks! Just get rid of Download as you can 'Download vCard' right in the main window.
0
Matt Petty Replied
Employee Post
Yea, I just pulled the download button out.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
kevind Replied
Confirmed that this is fixed in 15.4.6151. The Delete button now works and the Download button is gone.
 
However, there is still an issue. When you Edit a contact then click Delete, it closes the window and shows a bunch of N/A's where the Contact info used to be. It should move to the next Contact like it does when you click Delete without going into Edit mode first.
 
Suggestion:  There are at least 2 other ways to delete a contact, so just replace the Delete button with a Cancel button to abort the Edit.
0
Larry Duran Replied
Employee Post
I took a quick look at this and the delete button from the edit modal was just missing some meta data for the delete to function like the other deletes. I added this info and tested it out on my end and it works as expected so this fix should be in the next minor release.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
Great! That darn meta data -- always causing problems :-)

Reply to Thread