SmarterMail Uninstall Fails - 1628: Failed to complete installation.
Problem reported by Terry Matchett - November 8, 2015 at 8:06 PM
Submitted
HI,
Was trying to do the minor upgrade to SmarterMail tonight and following the steps according to the guide but when I tried to uninstall SmarterMail i received the error  1628: Failed to complete installation. This happened right after the initialization so the current installation was not affectedI tried multiple times and even rebooted the server.  Has anyone else run into this before?  If so would like to know how you got past this.
Dave

5 Replies

Reply to Thread
0
Rod Lasky Replied
Employee Post
Hi Dave. In the Control Panel, do you see SmarterMail installed twice? I'm wondering if both the full installer and the MSI version are both installed...
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Terry Matchett Replied
No, there is only a single listing for SM. That's the frustrating part.
0
Brad King Replied
Did you ever find a solution to this?

I had two listings of SmarterMail, one uninstalled successfully, the other didn't. Now I'm unable to install the new version.
0
Christopher Delk Replied
Any additional information with the 1628 error?  Trying to upgrade from SM14 (14.2.5711) to SM15 and it will not uninstall.  Gone through the basics (server restart, re-reregister windows installer, scan for malware).  Only one copy of SM showing in Add/Remove Programs and IIS is stopped when trying to uninstall.
 
Thanks,
0
Jay Altemoos Replied
This error sounds familiar to me. This may or may not be your issue, but I ran into issues with SM on one of my servers that the SmarterMail web server service would not uninstall after uninstalling SmarterMail through the Programs and Features section. The SMWebsvr service would hang around afterwards. Check the services manager and see if SmarterMail Web server is still there after you uninstalled SmarterMail. If it is, you are probably running into the same issue I ran into on my secondary server. When the service gets abandoned, the installer tries to put it back again but it's already there and the update halts with an error. I can't remember off the top of my head what the exact error is, but it's a fairly simple fix if this is your issue.
 
So when this happened, I got into the habit of first uninstalling SM on that server and then through the command line I executed: sc delete SMWebSvr    The SMWebSvr service is the built in web server that comes with SmarterMail.
 
After that install the new update and all went fine during the update installation for me.

Reply to Thread