Outlook for Mobile (iOS & Android)
Question asked by Scarab - 10/9/2015 at 2:01 PM
I have a customer using Outlook for Mobile devices to connect to SmarterMail with ActiveSync. All of a sudden, beginning this morning he is getting the following error in Outlook for Mobile:
File: outlook\pstprx\storeas\utils\airsyncstatuscodes.h
Line: 226
HTTP/1.1 403 Forbidden
MailStatus: 403
To re-try press F9...
Error Code:    0x80004005
Everything seems fine in the SmarterMail ActiveSync logs but in the IIS Logs I find the following:
2015-10-09 20:38:55 W3SVC1 POST /Microsoft-Server-ActiveSync User=user%40domain.com&DeviceId=6F13EF5D46DE2A20&DeviceType=Outlook&Cmd=Sync 443 - Outlook-iOS-Android/1.0 403 0 0 1541 520 31
This error has been repeating every 30 seconds since this morning.
We tried removing and re-adding the account in Outlook for Mobile but problem persists and tried adding the following to our web.config
            <requestFiltering allowDoubleEscaping="true" />
Still problem persists.
Does anyone have an idea what could be causing this or how to fix it?

3 Replies

Reply to Thread
Employee Replied
Employee Post
Hi Scarab.  In your SmarterMail IIS site, do you have any other authentication method enabled besides anonymous?
I'm not sure where else the issue may be, I've had an EAS account running on Outlook for iOS for a few weeks now.
Scarab Replied
Nope, only Anonymous Authentication is enabled.
Scarab Replied
I may have found the problem. The user had 7 devices activated with Exchange ActiveSync for this account. 5 of these devices were synching simultaneously. The first four would have no problems, but the fifth would generate the error every 30 seconds. Had the customer turn off one of the other devices and the error went away on the last device.
So, apparently there is a limit to the number of active devices using Exchange ActiveSync on the same account, and exceeding that limit results in the HTTP rsp "403 Forbidden".

Reply to Thread