Upgraded to SmarterStats 10 breaks UNC share access
Problem reported by Dave Lerner - September 1, 2015 at 8:04 PM
Not A Problem
We were running SmarterStats 9. We have the server accessing the logs on another server, so used UNC option to allow access. No problem.
 
Along comes version 10...sigh, we upgrade, and find that they have included a new "feature" that allows you to override the default UNC credentials so that each site can use its own credentials. Well, that's a nifty little "feature" (of dubious utility, but I digress...), but the developers set up the software so, get this, the tick box for "Use Default UNC Settings" is CLEARED ....and thus, it means that each site is now set to use its own credentials, i.e., overriding the default UNC credentials, with the eminently useful set of blank username and password.
 
This basically causes all log processing to halt as none of the sites can now log in.
 
Why was this done like this? How can we now modify all the sites to set them back to log in with the default credentials? I mean, guys, how could you have published this with that setting to "False"? By default, version 9 used only one global set of credentials, and therefore, that would make that tick box "True" for all sites...why would you not make it backward compatible?
 
I have told the client to submit a ticket and make support fix this...its unbelievable that this happened. Wow.

2 Replies

Reply to Thread
0
If this has happened to you, don't wait for Smartertools support to fix it for you. Use SED (cygwin, or rktools, etc), or any other search-and-replace tools to edit all your config files.
 
The config files for each site are found, normally, in C:\Program Files (x86)\SmarterTools\SmarterStats\MRS\App_Data\Config\Sites. Make a backup of the files, then change the following line:
 
    <UncUseSystemDefaults>False</UncUseSystemDefaults>
 
to
 
    <UncUseSystemDefaults>True</UncUseSystemDefaults>
 
 
...in all the *.xml files. Then, restart the smarterstats service, all will be back to working normally. I used the command line For and SED commands like this:
 
for /r %%i in (*.xml) do sed s/"UncUseSystemDefaults>False"/"UncUseSystemDefaults>True"/g %%i>%%1x
 
This left me with all the same files with a trailing "x"...some simple copies/renames, etc, got me back all my xml config files with the UNC setting set so it uses the default login...like it should have after the upgrade.
 
I believe this was an oversight by the smarterstats development team...and, granted, most users do not use the UNC option...but we did.
 
 
0
Employee Replied
Employee Post
There seems to be some confusion regarding UNC paths and when credentials are needed.  With SmarterStats 10.x, the ability to specify a UNC path and credentials on a per site base was introduced.  This allowed system administrators to setup UNC paths for sites that might have different credentials needed to access the UNC path.
 
In previous versions of SmarterStats, if you were trying to access a UNC Path that required specific credentials (i.e. - \\SERVERNAME\C$\FOLDER NAME\ ), you needed to modify the SmarterStats service after it was installed to login with an account with valid permissions to access the path.
 
Now in SmarterStats 10.x - you still have the option of modifying the service to use a different account.  The SmarterStats Service is installed using a 'Local System' account, so if the log path your trying to access needs permissions to reach the path - modifying the service is one option.
 
Alternatively, you can use the Default UNC Credentials option as you described.  The reason that this was set to disabled by default is that this is a new setting added to SmarterStats 10.x.  All previous versions of SmarterStats would have used the method described above by modifying the service to access the path.
 
One item to note regarding this, is that I can see where a site propagation setting for using UNC defaults is needed.  That has been added to the list of future changes to SmarterStats 10.x.

Reply to Thread