Contacts - 'Select All' doesn't work as expected
Problem reported by kevind - 6/25/2015 at 10:05 AM
Resolved
Common situation: User would like to send an email to contacts who are all tagged as 'Family' with a master category. Since you can't type a category in the To: when composing...
 
  1. In SM14, navigate to Contacts.
  2. Click View -> Filter -> Category and pick a category to reduce 100+ contacts to the 14 you want.
  3. Click Actions -> Select All
  4. Click Actions -> Send Email and the message gets addressed to _all_ your contacts instead of the 14 shown on the screen.
When fixing this, why not get rid of the Select All in the Actions menu (there is no Select None) and just put an intuitive checkbox in the header where you can check/uncheck to select all/none (just like SM uses for the Inbox).
 
Thanks,
Kevin

5 Replies

Reply to Thread
0
Robert Emmett Replied
Employee Post
Thank you, Kevin, for bringing this bug to our attention.  I have been able replicate the issue.  It has been added to our bugs list.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Brian Ellwood Replied
+1 for the checkbox to remove the menu item
0
Matt Petty Replied
Employee Post
The next minor for 13 and 14 will have this fix.

Also, If you do Select All when everything is selected is deselects everything.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
kevind Replied
Great, thanks for the fix!

And yes, I know you can Select All to unselect all, but just thought a checkbox like what's used for Messages, Calendar Appointments, RSS Feeds, File Storage, Trusted Senders, etc. would keep the UI more consistent and easier to use. :)
0
Matt Petty Replied
Employee Post
The text has been changed to Select / Deselect All to better reflect what it does.
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread