Automated reports are sent without From field
Idea shared by Marco Nylund - September 23, 2014 at 2:22 AM
Under Consideration
When we are sending automated reports ie. Domain Diskspace report to our customer, who has an Exchange server in use, the server will automatically deny this email, because the sender from field is empty. It would be nice to able to define the "from field" for these automated reports.

9 Replies

Reply to Thread
0
Marco, thank you for your comments.  Exchange 2013 does deny email without sender in the header.  I have added this to our feature request list for implementation in a future major release.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Your customer's Exchange 2013 can be configured to accept e-mail from NULL senders.
 
The fix is described in Microsoft TechNet at: http://technet.microsoft.com/en-us/library/aa997469(EXCHG.80).aspx
 
Here's the short method:
  1. Open an Exchange Shell
  2. Set-SenderFilterConfig -BlankSenderBlockingEnabled $false
 
Tried to embed an image showing commands from TechNet, but the image is not populating.
 
Here's a link to the image: 
 
 
More information on configuring Exchange 2013 filtering is available via this Microsoft TechNet article:
 
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
That is the way, that we have also fixed this problem
1
A new KB article has been created which addresses this issue - for now, simply mentioning the Exchange workaround that can be done. This item is under consideration for a future version to allow the From field in these emails to be defined. Thank you, Bruce, for your suggestion on the workaround. 
 

Andrea Rogers
Communications Specialist
SmarterTools Inc.
(877) 357-6278

www.smartertools.com

0
Hello, this not work for me.
I have Exchange 2013, I try 

Set-SenderFilterConfig -BlankSenderBlockingEnabled $false

but email report from SmarterMail is rejected.
When I execute the command above, I receive this warning:

the command completed successfully but no settings of 'SenderFilterConfig' have been modified.

Whit command Get-SenderFilderConfig, the value of BlankSenderBlockingEnabled is False.
GRAFFITI — It's Communication
Riva del Garda (TN), I-38066 – Località Pasina 46
Milano, I-20129 - via Lamberto De Bernardi 1
Verona, I-37134 - via Legnago 126
San Francisco, US-94111 California – 275 Battery St, Suite 2600
website: www.graffiti.it
1
Exchange Server 2013 requires another modifier in the line: "-RecipientValidationEnabled"
 
 
Set-RecipientFilterConfig -RecipientValidationEnabled $true
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
0
Hello Bruce,
the value of RecipientValidationEnabled is false on my server, and with this value, Exchange reject blank sender.
I try to set true, but problem persists :|
GRAFFITI — It's Communication
Riva del Garda (TN), I-38066 – Località Pasina 46
Milano, I-20129 - via Lamberto De Bernardi 1
Verona, I-37134 - via Legnago 126
San Francisco, US-94111 California – 275 Battery St, Suite 2600
website: www.graffiti.it
0
Did you restart the Exchange server or reboot the server?
Bruce Barnes
ChicagoNetTech Inc
brucecnt@comcast.net

Phonr: (773) 491-9019
Phone: (224) 444-0169

E-Mail and DNS Security Specialist
Network Security Specialist

Customer Service Portal: https://portal.chicagonettech.com
Website: https://www.ChicagoNetTech.com
Security Blog: http://networkbastion.blogspot.com/

Web and E-Mail Hosting, E-Mail Security and Consulting
1
2017 now and it is still noct possible to set the sender of a report...

Reply to Thread