Cannot Open the "domain -> Manage -> Users" Page
Problem reported by Manish Naik - 1/6/2015 at 2:04 PM
Not A Problem
Greetings,
 
We use the latest version of smartermail and we have installed it just last week.  We are using Enterprise unlimited users version.  Windows 2008 R2 and we are using Smartermail Web server instead of IIS. We are using a windows instance on Amazon. 
 
Everything was working fine, but we just imported users using the Import from CSV tool and all hell broke loose.
 
Now we cannot open the "Domain -> Manage -> Users" Page.  It just says the following :

Oops!

There was an issue that caused this page to malfunction.

Administrators

This error has been logged and can be found in the View Logs page as well as in the file system. If you have questions, please refer to the Online Help or SmarterTools Knowledge Base.

We cannot add/modify users.  The existing users work fine, login/logout/email, etc.  But I cannot open the Manage Users Page. 

Additionally, we created another domain "xyz.com" and surprisingly everything works fine in the new domain, but the existing domain is yet not allowing to open users.

We have tried the following :

1. We ran the Setup again and selected Repair.  - No Luck

2. We ran the Setup - Removed everything - without the mailboxes and settings - and reinstalled - No luck

3. We tried rebooting the server. - No luck

4. We tried restarting the services - No Luck

5. I tried to copy the domainConfig.xml file from the new domain to the old domain - No Luck

We are getting the following errors constantly in the xmpplog.log file

xmpplog.log
20:43:28 ERROR: System.Net.HttpListenerException (0x80004005): The process cannot access the file because it is being used by another process
   at System.Net.HttpListener.AddAllPrefixes()
   at System.Net.HttpListener.Start()
   at MailService.TcpServerLib.XMPP.BoshListener.Start()
 
Also the error logs Logs the following everytime we try to open the Manage -> Users Page
 
[2015.01.06] =======
[2015.01.06] [CurrentUser: administrator@teammail.co.in]
[2015.01.06] [1/6/2015 8:55:39 PM]
[2015.01.06] http://172.31.44.145/DomainAdmin/frmUsers.aspx
[2015.01.06]
[2015.01.06] System.ArgumentException: An item with the same key has already been added.
[2015.01.06]    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
[2015.01.06]    at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
[2015.01.06]    at System.Linq.Enumerable.ToDictionary[TSource,TKey,TElement](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)
[2015.01.06]    at SMWeb.DomainAdmin.frmUsers.PerformSearch(UserData[] original, UserMetaData PageMetaData)
[2015.01.06]    at SMWeb.DomainAdmin.frmUsers.GetGridDataSource(String sessionKey, Int32& virtualCount, Int64& lastUpdate, Int32 low, Int32 high)
[2015.01.06]    at SMWeb.DomainAdmin.frmUsers.GenerateGrid(SuperHyperGrid hyperGrid1, Boolean isCallback, String sessionKey)
[2015.01.06]    at SMWeb.DomainAdmin.frmUsers.GenerateGrid()
[2015.01.06]    at SMWeb.DomainAdmin.frmUsers.Page_Load(Object sender, EventArgs e)
[2015.01.06]    at System.Web.UI.Control.OnLoad(EventArgs e)
[2015.01.06]    at SMWeb.HelperClasses.CustomPage.OnLoad(EventArgs e)
[2015.01.06]    at System.Web.UI.Control.LoadRecursive()
[2015.01.06]    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
[2015.01.06] Application Error
 
Any help would be appreciated.
 
Thanks
 
Warm Regards
 
Manish Naik

3 Replies

Reply to Thread
0
Andrea Rogers Replied
Employee Post
Unfortunately I don't have any troubleshooting tips on this, but I just wanted to quickly say thanks for providing so much information in your post! That's exactly what we like to see; detailed posts like this definitely help with initial troubleshooting.

Andrea Rogers
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
Robert Emmett Replied
Employee Post
Manish, I suspect that the issue has be do with a malformed CSV file or duplicate usernames within the CSV file.  I tried a few different scenarios to see if I could replicate the issue but with no success.  At this time, I would recommend opening a support ticket so that we can get your CSV file and/or look at your server configuration.  Keep in mind, if a bug in the software is causing this issue, your ticket will be refunded.
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Manish Naik Replied
Greetings Robert,
 
I suspected the same thing, however, when we deleted and created the same domain with the same parameters again, we uploaded the same CSV.  In fact, I was expecting the same error all over again, and I wanted that to happen, so I could try and figure out the problem.  Unfortunately, it just didnt give a problem again !  We also created a couple of other domains, and uploaded the same CSV, No problem !
 
And yes, today we have uploaded another 200 users from a different department already, no problem ! 
 
Finally, I just let it go.
 
The only worry I have is, we couldn't identify the problem, so if it happens again at some random point in time, we would be in a fix.
 
By the way, I had commented on Andrea's comment, how come it is not available on this page ?
 
Thanks for the response.
 
Warm Regards
 
Manish Naik

Reply to Thread