3
SmarterMail Build 8496 (Apr 6) In-Production Issues
Question asked by Ron Raley - 4/6/2023 at 5:04 PM
Locked
Unanswered
Please share your experience upgrading to the New SmarterMail Build 8496 In-Production.

Also, do you have positive / negative user feedback.

Ron

33 Replies

Reply to Thread
1
Andreas Meli Replied
good morning everyone, have dared the upgrade ;-), so far everything went according to plan. compliments at this point!

two things are noticeable:
1. the hoped-for function release calendar read-only shows the same behavior on the mobile device as with the old version smartermail - as soon as read-only is selected, the calendar is not visible in the mobile.

2. via webcal captured it works, but the view is not identical to the original - full day entry shows differently i will make a tickt with this.

thanks a lot for your great work!

am
1
Michael Replied
Some strangeness with MAPI/EWS from Outlook...
1. Outlook clients were not authenticating. Actually they just weren't communicating with the server. Going into each domain and toggling the max account limit for MAPI (in each domain) somehow refreshed something and Outlook clients are connecting. Phew!
2. When mailing from Outlook to gmail or anyone, the from address is not including the friendly display name on the account, just the email address. Display name is missing from the header. It's working from EAS, just not MAPI/Outlook/Exchange. This needs eyeballs.

Also... Strangeness with Message archiving.
We were using a non-standard archiving location "C:\SMArchive" - quite large 400GB+
After updating archiving was OFF.
We had to turn it back on with our Archive folder. We're now waiting to see if it works. But a little nervous here.
It seems we're only archiving NEW messages.
Unclear how we can see the archive of messages BEFORE the update?
2
Thomas Lange Replied
Thanks to SmarterTools that currently on issues with your big-update "Next SmarterMail" is being working on and that new builds available in a timely available!


Today I updated to build 8496 - becaues we needed the fix for our PDF-attachments
Fixed: An issue retrieving an attachment from an email that has no MIME sub-parts.
Yes, this is fixed - we are able to download/open PDF-attachment with eMClient/EWS-protocol.


EWS-synced-signatures and displaying differently comparing the eMClient-signature and EWS-synced this copied signature I will work on during next week - and see if I can redesign/rebuild so that is displays better.


notification/error messages with "allow_mail_forwarding is False":
I allowed this now for all users so that our external mail-archiving-software is working again and we are able to get all received and outgoing emials as a copy (add-recipient)
But I am not happy that now all users are able to edit/change forwarding addresses and settings on their own. Their should be a way that Global and Domian-Admin configured forwarding is possible - independently to individual user-account-setting.


Other behavior of the new buidl 8496 I will monitor over the weekend - but due to Easter this Friday and next Monday office is closed  - so I will not get any reports by our employees before Tuesday.
btw: Happy Easter

Regards,
Thomas



3
I agree with these sentences of Thomas:

notification/error messages with "allow_mail_forwarding is False":
I allowed this now for all users so that our external mail-archiving-software is working again and we are able to get all received and outgoing emials as a copy (add-recipient) 
But I am not happy that now all users are able to edit/change forwarding addresses and settings on their own. Their should be a way that Global and Domian-Admin configured forwarding is possible - independently to individual user-account-setting. 
Gabriele Maoret - Head of SysAdmins at SERSIS Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
2
Vahn Babigian Replied
We had the same problem with Outlook authentication. We also toggled the Mapi max account limit. In addition we noticed IDS (Denial of Service) was blocking our mailserver ips. We increased DoS connections. That worked for a little while. We have turned off DoS, for now. It seems to be working. 
3
Zach Sylvester Replied
Employee Post
Hello, 

Thanks for posting your feedback. 
The Outlook auth problem is rather interesting we will investigate what is causing you to have to toggle the Mapi account limit on Monday. Regarding your archives not showing @Michael try pressing the reindex archives button on the domain configuration page. We added this so if you add something or if something is wrong with your archives Smartermail can automatically recreate the search files. So please try this wait a bit and try again. 

Thanks, 
Zach Sylvester System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
1
Michael Replied
@Zach thanks for the post. About archiving... we see in the archive folder that the domains previously archived are in their own folders. but the new format seems to handle archiving differently. Pressing the re-archiving button will know to check in those domain folders within the archive?
1
Michael Replied
Vahn Babigian  we're seeing the same thing. Our main office that connects a lot with MAPI is coming up with DOS blocks. 2 odd things 1- why is it hitting the DOS block? It's sending right password. Seems related to the initial issue about needing to tweak the account limit/wake up MAPI.  but 2- the office IP is in the whitelist so it shouldn't come in DOS block. Seems Whitelist is being ignored too?
2
Mostafa Karimi Replied
We have some major issues too.
1- first of all and the most annoying one all MAPI (Outlook Client)  users cannot open Calendar meeting invitations with the error: Outlook does not recognize this Schedule + recurrence pattern. So they Cannot accept or decline the meeting unless they open their Calendar and navigate to the invitation, then they are able to open the email. that is not the end of the story, once they accept, it remains acceptable and won't move from inbox to deleted items.
2- TimeZone issues are there. I have submitted a support ticket therefore too and we are working around it with @Zach.  

3
BIG ISSUE: after the update to the latest snew SM (and even after 8496) an account doesn't sync with Outlook MAPI anymore.
Expecially the INBOX filder (Posta in Arrivo in Italian) that now is empty in Outlook, but it work OK in webmail and in Android via EAS and via IMAP in Thunderbird,

Even configuring a new PC with new Outlook account doesn't work. Tested with Outlook 2019 and Outlook 365.

No related exceptions in LOGS.

This is a really troublesome issue, fortunately I have only 16 account in the server that I upgraded.

I will wait to upgrade the other server (wich has nearly 1000 accounts...) until this is resolved 



UPDATE: it seems mostly related to INBOX.
The other folders seem (but not 100% sure...) to sync.

I'll open a ticket and a dedicated post to this issue
Gabriele Maoret - Head of SysAdmins at SERSIS Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
1
Jan Becher Replied
After upgrading, I have a few issues.

On one domain, the users cannot see ex. inbox, and the domianadmin (nad systemadmin) cannot see any of the users.

User connections and user statuses shows number of users but no details.

/Jan
2
Hi Jan! Your issue seems similar to mine, INBOX not working anymore in Outlook MAPI
Gabriele Maoret - Head of SysAdmins at SERSIS Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Jan Becher Replied
Hi Gabriele,

It's possible. I have only get a report from one domain, uding webmail.
/Jan
0
Hi Jan, I have no issue in WebMail... 
Only Outlook in MAPI mode and seems (not 100% sure...) only related to INBOX folder...

Meybe it's a different issue...
Gabriele Maoret - Head of SysAdmins at SERSIS Currently manages 6 SmarterMail installations (1 in the cloud for SERSIS which provides services to a few hundred third-party email domains + 5 on-premise for customers who prefer to have their mail server in-house)
0
Patrick Jeski Replied
I upgraded to 8496 this morning. I cannot log in to webmail with firefox, even as the site admin. I get the red "Username or password is incorrect.", but when I look in the administrative log, I see "Webmail Login successful:"

I can log in with microsoft edge.

I tried multiple accounts with two different computers.

Edit to add: Now I've had some luck logging into some accounts. Switching on "Remember Me" seems to enable the account, and after that I seem to be able to log in that account no problem regardless of the setting of "Remember Me". That also includes my site admin account.
3
Kyle Kerst Replied
Employee Post
@Michael: I recommend we get a ticket submitted so we can look at your existing Archive structure. In the new versions the domain-level archival settings are in the domain's settings, and the system-level is found at Settings>General at the system admin level. So, you might just need to go set those rules back up, or they may still be in place and are just not where you're expecting them to be. Once you have the rules turned back on and pointed at the existing directories, do a reindex and that should bring everything current. If that doesn't work please submit a ticket and we can take a look.

@Everyone: We're reviewing your feedback and will be in touch shortly with recommendations.
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
5
Employee Replied
Employee Post
Hi everyone, 

I wanted to let you know that we are reviewing the reports thus far and working through them one by one. I will be responding to each report with an update on where we're at thus far. 

EAS and Read-Only Shares
Andreas Meli: "1. the hoped-for function release calendar read-only shows the same behavior on the mobile device as with the old version smartermail - as soon as read-only is selected, the calendar is not visible in the mobile."
EAS won't sync read-only shared folders, and I'm afraid this limitation is out of our hands. EAS doesn't have a concept of read-only shared folders; it always syncs with full control - no matter what. This is the reason we hide read-only shared folders via EAS. 

WebCal Concern
Andreas Meli: "via webcal captured it works, but the view is not identical to the original - full day entry shows differently i will make a tickt with this."
I see that you have a support ticket started for this. We will review this with you and try to replicate this issue. 

Outlook MAPI Not Authenticating / DoS IDS Blocks
Michael: "Outlook clients were not authenticating. Actually they just weren't communicating with the server. Going into each domain and toggling the max account limit for MAPI (in each domain) somehow refreshed something and Outlook clients are connecting. Phew!"
Vahn Babigian: "We had the same problem with Outlook authentication. We also toggled the Mapi max account limit. In addition we noticed IDS (Denial of Service) was blocking our mailserver ips. We increased DoS connections. That worked for a little while. We have turned off DoS, for now. It seems to be working."
Michael: "we're seeing the same thing. Our main office that connects a lot with MAPI is coming up with DOS blocks. 2 odd things 1- why is it hitting the DOS block? It's sending right password. Seems related to the initial issue about needing to tweak the account limit/wake up MAPI.  but 2- the office IP is in the whitelist so it shouldn't come in DOS block. Seems Whitelist is being ignored too?"

I see a couple of people have reported something similar with the Outlook authentication. We will need to do some tests to see if this can be replicated locally. 

Vahn, Michael: we have not had any DoS blocks on our production servers. I have started a support ticket with each of you so we can review your logging directly. Regarding the whitelist and DoS rule: Because of how the connections happen, the DoS rule only counts connections for SMTP, POP, IMAP, XMPP and LDAP. Once an IP is blocked by a DoS rule for one of those protocols, the block is then applied to MAPI, EWS, EAS and WebDAV connections as well. This means that a whitelist SHOULD be expected to prevent a DoS block, since the rule only checks those protocols to begin with. As long as your whitelist includes all available protocols, it should have prevented the DoS block from taking place. 

Outlook MAPI Display Name
We replicated the issue with Outlook MAPI not using the user's Display Name on outbound emails. We will get this resolved. 

Message Archiving
Michael: "Strangeness with Message archiving. We were using a non-standard archiving location "C:\SMArchive" - quite large 400GB+. After updating archiving was OFF. We had to turn it back on with our Archive folder. We're now waiting to see if it works. But a little nervous here. It seems we're only archiving NEW messages. Unclear how we can see the archive of messages BEFORE the update?"
I wonder if this may just be confusion regarding the archiving changes. We relocated the settings for message archiving. The 'All Domains' rule is now set at system Settings > General, and the per-domain rules are now configured on each domain's configuration (Options tab). If you had per-domain rules configured pre-upgrade, you'll find those in each domain's Options tab now. However, we have a support ticket for this so we can look into this more, and we will update here accordingly. 

Automated Forwarding
Thomas Lange: "notification/error messages with "allow_mail_forwarding is False":
I allowed this now for all users so that our external mail-archiving-software is working again and we are able to get all received and outgoing emials as a copy (add-recipient)
But I am not happy that now all users are able to edit/change forwarding addresses and settings on their own. Their should be a way that Global and Domian-Admin configured forwarding is possible - independently to individual user-account-setting."
If the domain's Automated Forwarding setting is enabled, then domain-level Content Filters should allow the Forward Message action and domain-level events should allow the Add Recipient action. These two domain-level automated forwards should NOT be impacted by the users' automated forwarding settings. 

Outlook MAPI Invitation Emails
Mostafa Karimi: "first of all and the most annoying one all MAPI (Outlook Client)  users cannot open Calendar meeting invitations with the error: Outlook does not recognize this Schedule + recurrence pattern. So they Cannot accept or decline the meeting unless they open their Calendar and navigate to the invitation, then they are able to open the email. that is not the end of the story, once they accept, it remains acceptable and won't move from inbox to deleted items."
We were able to replicate this issue with all day appointments in Outlook MAPI. I see we have a support ticket opened. We will provide updates as they become available. 

Time Zone Issue when Viewing Calendar
Mostafa Karimi: We will continue troubleshooting this with the support ticket you have open. 

Outlook MAPI Not Syncing Inbox
Gabriele: "after the update to the latest snew SM (and even after 8496) an account doesn't sync with Outlook MAPI anymore."
We were able to replicate a similar issue and have a development task looking into this. We will continue working with you on your support ticket to gather the necessary information from you. 

Issue with One Domain Post Upgrade
Jan Becher: "On one domain, the users cannot see ex. inbox, and the domianadmin (nad systemadmin) cannot see any of the users. User connections and user statuses shows number of users but no details."
These issues both seem related to a JSON issue. We have a support ticket with you where we will continue troubleshooting this. 

Cannot Login via Firefox
pjeski: "I cannot log in to webmail with firefox, even as the site admin. I get the red "Username or password is incorrect.", but when I look in the administrative log, I see "Webmail Login successful:"..." 
I'm unable to replicate this issue. I have started a support ticket so we can review this with you directly. 
0
Rafael Grecco Replied
Hello!

While I have not upgraded my servers yet, I have a question regarding Message Archive:

My archive has over 8TB of data. Because of that, I move older files do a cold storage on the cloud. I keep 3TB of archive data on the server and older data on a cold separated storage.

That means that while users can search the Archive Message for old e-mails (the index file keeps the information of all e-mail), they can't actually open the e-mail to see the content - because the content is on a separate storage. When that is necessary, I manually move the required data from the cold storage to the server.

My question is: what happens when I reindex the archive?

1- Will it wipe the index file and create a new one based on the actual files on the folder?
2- Will it read the archive file and check if there are any extra messages on the folder that is not indexed to add it?

I really hope the option number 2 is how it's done.
0
Vincent Sammons Replied
EAS is not working syncing on Android phone.
Why don;t Smartermail report on EAS usage in reports? It will help with diagnosis of problems.
Vincent Sammons
1
Kyle Kerst Replied
Employee Post
@Rafael: When you reindex you'll find the DAT files updated with only the GRP data that is physically present on the server. So, after a reindex search results would no longer reference that data and so won't be able to open those results from a search page. 

@Vincent: Can we have you open your own thread as well, or submit a support ticket with us so we can help investigate further? We'll need to gather some additional details from you in order to get to the bottom of this.
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
0
Michael Replied
Calendar events from Google appear totally blank in Outlook (via MAPI). Blank in the Email portion. They show on the calendar. But the accept / reject / reschedule buttons inside the Email portion of Outlook mail are missing.

They look ok in Webmail and EAS.
1
Kyle Kerst Replied
Employee Post
Hey Michael! I just did a quick test on Gmail invites on our latest build and this is working in both webmail and MAPI, so this should be fixed in our next release.
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
0
Rafael Grecco Replied
@Kyle: So that means that it's impossible to move archive to another localtion and use the reindex feature. That's very bad for people that have large archives like me - 8Tb and growing.

I know that the Archive sometimes "misses" some e-mails. Sometimes some e-mails that are sent or received and are present on the GRP data do not get indexed. So being able to reindex it's very imporant.

Can you ask the Devs to add a step on how reindexing works? It should create a new index file based on the files that are physically present on the server (just like it does now) and then merge it with the current index file. It's very simple to compare both files (old and new index) and add only new (missing) .emls on the old/current index file. Messages should not be removed from the index, it also hurts some auditing  rules.

Thanks!
0
Vincent Sammons Replied
Request for diagnosing EAS issues. Add report on EAS usage in reports.We pay extra for this functionality but there is no reporting on it that I am aware of. Thank you for trying to make Smartermail better!
Vincent Sammons
0
Michael Replied
Kyle Kerst checking on timeline, does it look like a new build will publish today April 11?
1
Zach Sylvester Replied
Employee Post
Hello Rafael, 

I made a Youtube video on how to use the reindexing feature with SmarterMail. Please take a look at the following. After watching this let me know if you have any questions. And Michael as for when we will be releasing I'm unsure as we do not have an ETA. But I would keep an eye on the downloads page as it should be coming pretty soon. I uploaded this video in 4k 60 FPS but it looks like Youtube is taking a while to process it. 
 
Zach Sylvester System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
1
Rafael Grecco Replied
Hi Zach,

Thank you for the video. I understand how it's working. But did you understand the problem I'm getting?

My archive is too big and I have to move older files do another drive (cold storage), but I can't lose the indexing of those older files because they must appear on search results.

I would like the reindex function to add missing .emls to the current index file instead of creating a completely new one.

It could be done by comparing the newly created index with the old one and merging both files into a single one.

I can't delete old archive because of my customers require it (government, insurance company, medical, etc) but I can't keep 8Tb+ of data on the server itself. Can it be done?

Thanks.
1
Zach Sylvester Replied
Employee Post
Hey Rafael, 

I see what you mean here. That is currently not possible. One thing that you could look into is creating a Storage Space. This way you can combine your drives into one. 
https://www.pcmag.com/how-to/how-to-combine-multiple-hard-drives-with-windows-storage-spaces
In the meantime, I will escalate a feature request for you requesting the ability to split your archives across multiple drives. 

Kind Regards, 
Zach Sylvester System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
0
Kyle Kerst Replied
Employee Post
Rafael: The results will continue to display in search results, but you will not be able to interact with them (download or copy to mailbox) because the underlying EML data isn't present since you moved it to another location.
Kyle Kerst System/Network Administrator SmarterTools Inc. (877) 357-6278 www.smartertools.com
2
Rafael Grecco Replied
@Zach my server is actually on the cloud. I don't have any physical server or drive, so I move older files to a cold storage. It's not even a drive, it's a service that require a API to connect and upload/download, which I do manually. So scalating a feature to use multiple drives would not solve.

@Kyle that's exactly how I do it now. When a customer need a message that is very old and is on the cold storage, they open a request and I manually transfer those files back to the server. The issue here is that when using the reindex function, the files that are on the cold storage would lose it's place in the index, because it recreates it reading the GDR files on the physical drive, deleting the old index file.

Maybe there could be 2 reindex functions. The normal one, which you currently have now (delete the index and recreate it from zero) and a second one, where it would read all files and if there is a file on the archive folder that is not on the index, just add it. But do not remove any existing entry.
0
Employee Replied
Employee Post
Hi Rafael, 

I would encourage you to create a new Community thread with these suggestions. The difficult part in maintaining a thread with such a broad topic like this is that individual ideas can get lost in the fray. Having a post dedicated to message archiving suggestions will allow other administrators to share their feedback, and allow tracking of any related changes. 

Vincent Sammons, I would suggest the same for your EAS suggestions. 

Kind regards,
0
Rafael Grecco Replied
Hi Andrea, I agree. I'm sorry I diverted this thread from its intended discussion. I have opened a new thread to discuss it.
1
Employee Replied
Employee Post
Hi Rafael, 

Thank you! I certainly don't intend to dismiss your feedback; I just don't want it getting lost. :) 

Similarly to having suggestions get lost among the mix... The downside of having a thread like this (one thread to contain all issue reports for a specific build) is that it makes it a little more difficult to manage feedback. Because all issue reports are contained in this single thread, we can't provide updates individually by changing the thread status. And it impacts the ability to receive updates on a single issue, as all 15 people subscribed to this thread will be notified on any topic discussed here (not just the issue they reported). 

I understand it's beneficial for those who are looking to upgrade, but issue reports and and request should be created as their own threads. As such, I'm going to go ahead and lock this topic. 

Kind regards,