1
Unable to select different sites from SmarterStats Admin
Problem reported by Pearson ITCompliance - 10/19/2022 at 6:12 AM
Submitted
Currently running build 8195 (Jun 9, 2022)
Logging on as Admin, with just two sites set up at the moment and only allowing us to connect to site 1. 
If I enter site 2 which the other site is set up as, I get an error popping up with incorrect user or password, but the same admin name and password will log me in on site 1SmarterStats Sign in 2.PNGtwo sites in SmarterStats.PNG
Andy

7 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Hello Andy. Do you have any error logs being generated by SmarterStats in and around the time you last tried to log on? Those logs can be found in:

C:\Program Files (x86)\SmarterTools\SmarterStats\MRS\App_Data\Logs

Also, if you log on as the system administrator can you impersonate the site from there, or does this fail as well?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Pearson ITCompliance Replied
Hi Kyle
The only files I can see are copied into attached doc (text files not allowed in upload) from the 20th and today (21st), if you require more information I am happy to oblige, bearing in mind the time difference between UK and USA.
Andy
0
Pearson ITCompliance Replied
Hi Kyle.

Q>>Also, if you log on as the system administrator can you impersonate the site from there, or does this fail as well? 
A>> If I don't enter any figures in the SiteID field, I can then see both customers details and select site 2 from there - see attached screenshot. 
It is just when entering Site 2 into the SiteID field, nothing happens and I get the incorrect SiteID, password or username error.



Andy
0
Pearson ITCompliance Replied
Hi Kyle, 
Have you managed to work out what is the issue as yet?

Regards

Andy
Andy
0
Kyle Kerst Replied
Employee Post
Hey Andy, sorry for the delay in getting back to you on this. I took a look at the logs but unfortunately they don't provide much in the way of clues. Its behaving as if the username, password, or site ID is incorrect and I'm not seeing anything to indicate it failed. If you open the developer console in your browser while trying to log in directly; do you see any errors there?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Pearson ITCompliance Replied
pqswebstats_Site1.txtpqswebstats_Site2.txtHi Kyle
No errors reported in Developer console when logging on as Administrator to Site 1 or site 2.
I have attached a couple of screen grabs showing we go straight in to Smarter Stats when logging on to Site 1 and the error showing "Site ID, username or password is incorrect" when logging on to site 2 using same credentials. 
Along with the screen grabs, I have also uploaded the HAR files (Renamed to text file) from the Developers Console to see if you can trace the issue. I've had a quick look by using my Beyond Compare program, but it helps if you know what to look for....
Let me know if you require any further details.

Andy
Andy
1
Kyle Kerst Replied
Employee Post
Unfortunately Andy I'm not seeing anything obvious here :-( Can you submit a ticket on this so we can dig into it together please?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread