2
IIS Issue running SM 15.5 on Windows 2019
Problem reported by Louis Vazquez - 8/23/2021 at 1:06 PM
Submitted
I just installed SM 15.5 on Windows 2019. I am running into a problem getting the web interface to run. I am getting this error. Looking in the web.config file there are no tags for override in that file. Anybody have an idea on how to resolve this?

Detailed Error Information:

                            
Module   IIS Web Core
Notification   BeginRequest
Handler   Not yet determined
Error Code   0x80070021
Config Error   This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File   \\?\D:\SmarterMail\MRS\web.config


Mark

4 Replies

Reply to Thread
1
echoDreamz Replied
Means your server level configuration has a section locked and Smartermail web.config cannot override it. You can change this in the iis manager. 
0
Kyle Kerst Replied
Employee Post
I think echoDreamz is correct, this looks like a system level setting is forcing something at the site level. 
Kyle Kerst
System/Network Administrator
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
echoDreamz Replied
Here is a copy of our feature delegation settings in IIS... I will caution though, our IIS install is dedicated to SM and SM only, we run nothing else, so our configuration works for us, if this server runs other applications, I would be careful adjusting anything you dont understand :).
0
Tony Scholz Replied
Employee Post
Hello Louis, 

To go along with what is stated above you can also make sure that "Network Service" has full permissions to the SmarterTools/SmarterMail folder. 

Thank you
Tony Scholz
System/Network Administrator
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread