4
Forwarded emails lose their attachments when using MAPI
Problem reported by Nick Jansen - 4/15/2021 at 2:33 PM
Resolved
I'm using SmarterMail Enterprise Build 7761. I noticed recently that when a MAPI user forwards an email that has an attachment, the recipient of that forwarded email receives the email, but the attachment is missing. The sender's Outlook shows that the email contains the attachment while it is being composed; and after sending, the sender's Sent folder shows the email with the attachment included.

Tests I did (recipient is my Gmail account for these tests, but I have also noticed the problem when the recipient is other users on this same SmarterMail server, and on other mail services as well):
1. Microsoft 365 Outlook Version 2103 (Build 13901.20400 Click-to-Run), MAPI, forward an email containing an attachment: recipient *does not* receive the attachment.
2. Outlook 2019 Version 2103 (Build 13901.20400 Click-to-Run), MAPI, forward an email containing an attachment: recipient *does not* receive the attachment.
3. Outlook 2019 Version 2103 (Build 13901.20400 Click-to-Run), MAPI, create a new email containing an attachment: recipient *does* receive the attachment.
4. Outlook 2019 Version 2103 (Build 13901.20400 Click-to-Run), IMAP/SMTP, forward an email containing an attachment: recipient *does* receive the attachment.
5. Thunderbird 78.9.1 (64-bit), IMAP/SMTP, forward an email containing an attachment: recipient *does* receive the attachment.

Expected behavior: When an email that contains an attachment is forwarded when using MAPI, the recipient of that email receives the email with the attachment.

Actual behavior: When an email that contains an attachment is forwarded when using MAPI, the recipient of that email receives the email without the attachment.

Is anyone else experiencing this same issue, or know what might cause it?
Thanks!

12 Replies

Reply to Thread
1
Kyle Kerst Replied
Employee Post
Hello Nick! Thanks for your report on this. I was able to confirm this behavior and have escalated the issue to our development team for review. Based on my review this appears to only affect a subset of attachments. If you submit a ticket I can link yours to that task so you get an update when its resolved. Have a good one!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Nick Jansen Replied
Thanks Kyle, I submitted a ticket just now!
2
Tim Uzzanti Replied
Employee Post
Please try build 7776 and let us know if it resolves your issue.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Smith 23 Replied
0
Nick Jansen Replied
Hi Tim,

Thanks for your reply. I am now using Build 7776 and still have the issue.

On Build 7776, I created and sent a test email containing a PDF attachment from my Gmail account to my account on the SmarterMail server, and the email and attachment were delivered correctly in Outlook 2019 via MAPI. I then forwarded that email from the same account in the same Outlook 2019 via MAPI back to my Gmail account, and in Gmail I received the forwarded email but the PDF attachment was missing. In my Sent Items in Outlook, I see a copy of the forwarded message, and it has the attachment there.

Thanks
3
Tim Uzzanti Replied
Employee Post
Just saw you have a ticket and there is an active task in development.  Expect a hot fix shortly.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Nick Jansen Replied
OK, thank you very much for the update!
0
Mike Mulhern Replied
Does anyone know if this issue was fixed in the latest release?  We are still experiencing the same problem after updating to 7776.
1
Tim Uzzanti Replied
Employee Post
We are aware of the issue and its in development. New mail release could be out as early as end of week.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
J Lee Replied
Any news on a release that fixes the missing attachments while sending locally with MAPI?

J. Sebastian Lee Service2Client LLC 6333 E Mockingbird Ste 147 Dallas, TX 75214 - 877.251.3273

3
Tim Uzzanti Replied
Employee Post
Today
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
2
Nick Jansen Replied
Thanks; this appears to be resolved in Build 7793!

Reply to Thread