In Webmail - An Option To Exclude Aliases in Reply
Idea shared by Adam Lewis - 4/8/2021 at 6:39 AM
Hopefully this makes sense, but I would LOVE to be able to exclude aliases from "Reply All" replies, specifically single-recipient aliases in my case. So far, the only way I've been able to do so is by enabling the "alias can be used as from address in webmail" option, but then that makes me send as the alias which I don't really want.

Here's an example - 

My primary email is adam@domain.com. I have an alias of alewis@domain.com of which the only recipient is adam@. Whenever someone emails alewis@ and I receive it, I click "Reply All" the reply also adds alewis@ to the TO field so then I get a copy of my own email unless I remember to remove the alewis@ from the TO list. Also, the person that emails me now sees that I am copying myself on an email, which sometimes looks funny and suspicious. If I enable to the "alias can be used as from address in webmail" option then instead of copying myself, I send out as alewis@ which is *okay* but not ideal, because that's not the email I want to use.

I can see a few different options to solve this - 

1) An option on the alias setup (where "alias can be used as from address in webmail" option is) that says something like "exclude this alias from replies" and if it's enabled, it is simply always excluded from replies

2) A global option that says something like, "exclude single recipient aliases from replies" which would do just that. If an alias only has one recipient, meaning it was truly an alias for a user then it wouldn't be included in replies. I think the term alias is only actually valid if its a 1:1 relationship with a user, otherwise it's more like a group or list.

4 Replies

Reply to Thread
Not sure this would work. It would work if you are on the same server but that is it. 

I would propose doing the same functionality that Exchange does. If it receives an email for a person on one, or more, aliases that the email system be smart enough to know this and only deliver one email rather than multiple to that user.
@John Marx

That wouldn't really solve the issue. I only get one copy of the email now - but I don't want ANY copies, as I'm the one sending the email. This is purely a webmail issue, so either of my solutions are viable.
So when you send from an alias a copy is sent to the inbox? That just seems F'd up. You should only receive if you add to the to, cc, bcc. That would be my feature request but ok.
No, that's not the issue.

The issue is, if something emails alewis@domain.com, which is an alias for adam@domain.com, and then from webmail I click "Reply All", "alewis@domain.com" is automatically added to the TO: field

Reply to Thread