Searching Outlook 2016 using MAPI returns errors and is also very slow (SM 7579)
Problem reported by Gabriele Maoret - SERSIS - 10/9/2020 at 2:47 AM
Submitted
Testing MAPI with Outlook 2016 in SM 7579.

When I do a search in a big folder, Outlook returns me this advice:



My settings are already configured to use CACHE mode and ALL mantained offline







It is also very slow compared to the same search done on Exchange account (I did the account migration and the content is exactly the same)


9 Replies

Reply to Thread
2
Gabriele Maoret - SERSIS Replied
PLEASE NOTE: this is a very serious problem that affects the possibility of giving service to customers, because they would DEFINITELY start opening assistance tickets and complaining ...
1
Nathan Y Replied
Gabriele, you are not alone, we have encountered it too. We see it generating very high CPU on the server side. This is one of the reasons we cannot deploy MAPI to users.
1
Heimir Eidskrem Replied
CPU utilization is a problem.
Right now as I am typing this we have 31 connections.
1 stmp, 20 imap, 1 pop, 6EAS and 3 MAPI.

Server is running at 90+% cpu, build is 7573

We have only migrated a few domains and stopped migrating due to the issue.
Im sure it will be sorted out soon.  


0
Heimir Eidskrem Replied
Mail server stopped responding during the night and found a 98gb mapi log file this morning.


0
Larry Duran Replied
Employee Post
Hey Gabriele, can you open up a support ticket for this issue?  We'll probably need to get a Fiddler trace at the very least and maybe some additional information.

We know if you only download part of your mailbox into Outlook, then do a search,  and then tell it to find more on the server it could take a while.  We have future plans to look into that issue.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Hi Larry, I think you haven't read what I wrote...

I know that partially syncronized mailboxes have problems, BUT my settings are already configured to use CACHE mode and ALL mantained offline AND Outlook is FULLY SYNCRONIZED
And I DON'T tell outlook to find more on server...






Every single simple search has this error.
0
Gabriele Maoret - SERSIS Replied
P.S.: when I do such a search there's high CPU usage spikes on the server side...
2
Larry Duran Replied
Employee Post
Right.  So open up a support ticket and we'll gladly look into the issue.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
OK! I think I'll open it in the next 3-4 days (unfortunately I'm out of office now)

Reply to Thread