User Password Retrieval
Question asked by Giovane Heleno - 8/10/2020 at 1:23 PM
Answered
User password recovery email is rejected by gmail.
It does not contain the "from" field.
Where am I going wrong?


[2020.08.10] 15:33:13.187 [73243] RSP: 250-mx.google.com at your service, [x.x.x.x]
[2020.08.10] 15:33:13.187 [73243] RSP: 250-SIZE 157286400
[2020.08.10] 15:33:13.187 [73243] RSP: 250-8BITMIME
[2020.08.10] 15:33:13.187 [73243] RSP: 250-ENHANCEDSTATUSCODES
[2020.08.10] 15:33:13.187 [73243] RSP: 250-PIPELINING
[2020.08.10] 15:33:13.187 [73243] RSP: 250-CHUNKING
[2020.08.10] 15:33:13.187 [73243] RSP: 250 SMTPUTF8
[2020.08.10] 15:33:13.187 [73243] CMD: MAIL FROM:<> SIZE=1811
[2020.08.10] 15:33:13.374 [73243] RSP: 250 2.1.0 OK w4si12368610plz.61 - gsmtp
[2020.08.10] 15:33:13.374 [73243] CMD: RCPT TO:<xxxx@gmail.com>
[2020.08.10] 15:33:13.874 [73243] RSP: 250 2.1.5 OK w4si12368610plz.61 - gsmtp
[2020.08.10] 15:33:13.874 [73243] CMD: DATA
[2020.08.10] 15:33:14.062 [73243] RSP: 354  Go ahead w4si12368610plz.61 - gsmtp
[2020.08.10] 15:33:14.359 [73243] RSP: 550-5.7.1 [x.x.x.x      14] Messages missing a valid address in From:
[2020.08.10] 15:33:14.359 [73243] RSP: 550 5.7.1 header, or having no From: header, are not accepted. w4si12368610plz.61 - gsmtp
[2020.08.10] 15:33:14.359 [73243] CMD: QUIT
Giovane Heleno
CTO / Faster Datacenter
Brazil 🇧🇷

4 Replies

Reply to Thread
0
Ronald Raley Replied
Interesting.  I no longer see "postmaster address" under Settings > General > Server Info

Where did it go?

For each domain, under miscellaneous, there is a Postmaster Mailbox input.  However, we do not have this set on any of our domains.  This setting may fix your issue in the meantime.

Our mail server uses a top-level single postmaster mailbox where I can no longer find the setting to.

Ron
0
Sébastien Riccio Replied
Marked As Answer
Hello,

these are system messages and I think you can configure the "From" address for these messages in the System messages configuration options, for example, for the password reset:


When you edit the entry:


However as explained on the settings page, if it is left blank it should default back to noreply@domain (where domain is the domain of the e-mail address being reset, I guess).

I would first check what is your current value for this. If it is actually blank and gmail is complaining about a missing From header, I would say there might be a bug here.

You could set it manually to something you would like to be the From adresss for these messages to see if it fix the problem.

Kind regards
Sébastien Riccio
System & Network Admin

0
Giovane Heleno Replied

The field was really empty.
I put a valid value and it worked correctly.

Thank you.
Giovane Heleno
CTO / Faster Datacenter
Brazil 🇧🇷
0
Sébastien Riccio Replied
Glad to help, Giovane.

Sébastien Riccio
System & Network Admin

Reply to Thread