2
MAPI with Remote Desktop Session Host Role
Problem reported by Liam Dwyer - 7/6/2020 at 11:43 AM
Resolved
Bit of a background..

I have a client using Windows Server 2012R2 setup in a Citrix XenDesktop configuration.  When I was attemting to convert them from Outlook IMAP to MAPI we ran in to the old error message:

"Cannot start Microsoft Outlook.  Cannot open the Outlook window.  The set of folders cannot be opened.  Network problems are preventing the connection to Microsoft Exchange"

The MAPI account setup progressed properly and "appeared" to setup correctly, however when launching Outlook afterwards, the error appears.

Troubleshooting ...

This MAPI domain works perfectly from any other computer on the network, and remote to the network, except from computers with the Remote Desktop  Services Session Host Role.

I setup a clean Windows Server 2012R2 with the same version of Office.  Fully updated Windows and Office.

Connected remotely to the server with Remote Desktop and was able to setup the email account and launch Outlook successfully.

Installed the Remote Desktop Services Session Host role and restarted.

Connected to server again and Outlook still launches and functions correctly.

Removed the Outlook profile completely.  Cleared the Outlook folders. Reset the connection in Webmail.  Tried adding the MAPI account again and it adds successfully, but the error appears when launching Outlook.

Remove the Session Host role again.  Outlook still errors.

If I clear the profile and recreate it (with the Session Host role not installed), the account setup works and Outlook is able to launch.

The issue seems to be with adding the account with the Session Host role installed.

I looked at the autodiscover.xml files that Outlook creates and they appear to be identical either way.

Liam Dwyer

3 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post
Thanks for your issue report on this Liam, I'd like to get some testing set up on this and will keep you posted on what I find out. Can you go ahead and submit a ticket on this? If we're able to reproduce the problem we'll want to get this over to development for resolution. Thanks in advance Liam!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Kyle Kerst Replied
Employee Post
Update: This has been created as a ticket for further investigation. Will follow up here with results when complete as well.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Kyle Kerst Replied
Employee Post
Resolution: The root cause behind this issue was identified to be how the Terminal Services role addition modifies the default behavior for usage of Use Cached Exchange Mode in Outlook. What we found is that choosing the Let me set up my account manually option when adding accounts should bypass the issues preventing Outlook loading on the TS environment:
After you choose Exchange as the option to connect with make sure you have Use Cached Exchange Mode checked:
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread