Ghost (blank) emails on iphone
Problem reported by Jane Noel - 7/1/2020 at 10:34 AM
Not A Problem
I'm running Build 7242 (Oct 30, 2019) and I have an iphone user who keeps getting blank emails.

They are fine in Webmail and when she's on Outlook on her computer, so I don't think the mails are corrupted.

She does not have internet service at home and uses her dataplan to check mails. She has poor service and often has connection issues.

The thing is that even when she gets back on a network, those emails are forever blank. Refreshing/resending/reloading doesn't help. Restarting doesn't help either.  We thought the phone was an issue so she went and got a new phone. The same behavior happens on the new phone too.

Any ideas of what I can do with this? I think it's more of an iphone problem than a Smartermail problem.

5 Replies

Reply to Thread
0
Sébastien Riccio Replied
Hello,
What protocol is used on the phone POP/IMAP/EAS ?

Also if you search for "grp" in IMAP and POP logs in troubleshooting, do you have any entries about corrupted grp or "cannot retrieve" something.

Just asking because we have some customers with the same issue and have been seing these kinds of log entries. Not sure they are related though but maybe it could confirm...

EDIT: forgot to ask, which build are you running ?

Kind regards
Sébastien Riccio
System & Network Admin

0
Jane Noel Replied
The phone is using IMAP.

I'll check the logs...but I've seen corrupted emails on iphones before.  When the iphone corrupted the mail, it wasn't readable/accessible in webmail either.

These are all fine in webmail, just not on the phone.  Even on the new phone.

One experiment we're testing is using a different mail app. I read a fair number of posts about ghost emails on the iphone (that had nothing to do with Smartermail.)

She's just been using the default iphone email app. I found one called myMail that seems like it's working.  The messages that the default app sees as a ghost email is appearing correctly on the myMail app.

But we need to wait for the client to leave the network and go home to her poor internet to see if that solves the problem.
0
Sébastien Riccio Replied
Yes, of course it can also be a iphone side problem, all tracks are good to folllow.
Sébastien Riccio
System & Network Admin

1
Gabriele Maoret - SERSIS Replied
You are on an old SM version. There's a lot of bug fixes in the latest releases, and some of those are related issue with IMAP and/or iPhone.

I suggest to check the release notes and update your SM server to the latest stable release 7482
1
Tim Uzzanti Replied
Employee Post
Mail on iOS has a number of issues and this is one of the more common ones and affects all protocols and servers including Exchange, Office365 etc.  It's heavily discussed on the Apple Support community and here is a random topic I chose as an example:  https://discussions.apple.com/thread/250688588

Apple hasn't been fixing as many bugs the last couple years because they have been focused on rewriting all their applications to be universal across MacOS, iOS, iPadOS using Project Catalyst.  This was a critical transition for them as they are also moving MacOS (MacBooks, iMac's, etc.) to ARM architecture instead of Intel.  Although we have all had to deal with more bugs, Apple made the right choice and it will give them a significant competitive advantage.  Apple currently has BETA's of everything and will be releasing to production in the Fall.

Hope this helps.
Tim Uzzanti
CEO
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread