Outlook 2016 cannot fully synchronize with SM BETA latest version via MAPI. After a while it fully stops updating.
Problem reported by Gabriele Maoret - SERSIS - 5/19/2020 at 6:19 AM
Being Fixed
I migrated a test user from an Exchange server to SM 7440 with MAPI active (migration seems to have completed successfully!).

The next step was to create an account on my Outlook 2016 and try to use the SmarterMail user.

At first it seemed to be all right and the MAPI account connected without problems, but after a while Outlook stopped synchronizing with SM long before completing the reception of all the data (only INBOX have elements in it, but only half than webmail. All other folders in Outlook are empty).

Now anything I do on Outlook doesn't sync with Webmail and vice versa.

It seems to be related to that:

Known issues for this build:
  • Reports of MAPI stalling on a folder.  Temporary workaround is to right-click the folder in Outlook, choosing Properties, and selecting Clear Offline Items.

But even if I try to do as indicated the sync stops again after a while (or never restart at all!) and Outlook never gets everything synchronized as it should.


Sadly, there's no exceptions in the MAPI log...

9 Replies

Reply to Thread
0
Larry Duran Replied
Employee Post
Can you check to see if you have any messages in your 'Sync Issues' folder during the time you tried syncing.  You will find the folder in the 'Folders' view in Outlook.  The 'Folders' view should be in the bottom left corner of Outlook in the '...' menu, which should be next to either the 'Tasks' or 'Notes' icon.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Hi Larry! 
No, I haven't any message in Outlook "sync issue" folder or subfolders
0
Gabriele Maoret - SERSIS Replied
P.S.: Now the sync is fully stopped. Even if I "Clear Offline Items" Outlook doesn't sync anything anymore...

But it is connected to the server, I can view that here:



0
Gabriele Maoret - SERSIS Replied
I have deleted the Outlook account, cleared the APPDATA Outlook folder and deleted EWS and MAPI connectio in webmail.

Recreated a new Outlook profile and connected to SM via MAPI.

Now let's see if it will stops syncing again...

UPDATE: the sync stops again... Now I will upgrade to SM 7444 and try again with clean accounts
0
Gabriele Maoret - SERSIS Replied
This post has been marked as RESOLVED by mistake.

Can you correct it and put it as UNFIXED?
0
Gabriele Maoret - SERSIS Replied
Same issues in 7444
0
Gabriele Maoret - SERSIS Replied
Tested SM 7445 --> the problem of blocking the synchronization between Outlook and SM MAPI seems solved, however in my opinion there is still something wrong, because the Outlook data does not correspond to the SM data (see images below) and there's no error in the MAPI logs.








0
Gabriele Maoret - SERSIS Replied
Even in 7447 th eissue is still here, Outlook some times stops to sync with SM.

Another info: there a issue with the Outlook Search while conneted to SM with MAPI:

0
Gabriele Maoret - SERSIS Replied
Still the same even in 7451:

Reply to Thread