[Beta] Outlook not updating more than 1 MAPI account
Question asked by echoDreamz - 4/23/2020 at 11:11 PM
Unanswered
I added 2 accounts to my Outlook install. The first one updates without issues, all folders get populated, I can watch the .ost file for it grow and grow will Outlook says "Updating .....". After 20 minutes or so, the first account completes and you dont see "Updating ...." anymore.

However, the second account, never updates, the ost file never grows even though Outlook says it is updating it. The only way I can get it to update folders for the second account is to manually select each folder. Outlook just contentiously says "Updating ..." without actually doing anything.

Using Office 2019, Outlook version 2003, build 12624.20466 Click-to-run.

11 Replies

Reply to Thread
0
echoDreamz Replied
Fiddler is showing an exception on the second account.

40d
Object reference not set to an instance of an object.
Stack Trace:
   at MailService.Protocols.Properties.ContactPropertyReader.RetrieveAllPropertyValues()
   at MailService.Protocols.MAPI.ServerHandles.FastTransferDownloadContext.FetchItem(Boolean isFai, UInt64 mid, Boolean restrictionChecked, db_folder_readonly dbFolder, Boolean& syncError)
   at MailService.Protocols.MAPI.ServerHandles.FastTransferDownloadContext.FetchItemIfNeeded(db_folder_readonly dbFolder, MapiPropertyContext mapiPropertyContext)
   at MailService.Protocols.MAPI.ServerHandles.FastTransferDownloadContext.GetBytes(Int32 maximumBufferSize, Boolean& done)
   at MailService.Protocols.MAPI.Rops.FastTransferRops.RopFastTransferSourceGetBuffer.Process(FastTransferDownloadContext fastTransfer)
   at MailService.Protocols.MAPI.Rops.FastTransferRops.RopFastTransferSourceGetBuffer.Process(List`1 payloadServerObjectHandleTable)
   at MailService.Protocols.MAPI.RequestTypes.ExecuteRequest.Process()
   at MailService.Protocols.MAPI.MapiProcessor.Process()
0
Exception in the mapi logs...

00:24:11.991 [{6DB9A068-A850-4B2E-A2EB-6290619D9E1F}:14] Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at MailService.Protocols.Properties.ContactPropertyReader.RetrieveAllPropertyValues()
   at MailService.Protocols.MAPI.ServerHandles.FastTransferDownloadContext.FetchItem(Boolean isFai, UInt64 mid, Boolean restrictionChecked, db_folder_readonly dbFolder, Boolean& syncError)
   at MailService.Protocols.MAPI.ServerHandles.FastTransferDownloadContext.FetchItemIfNeeded(db_folder_readonly dbFolder, MapiPropertyContext mapiPropertyContext)
   at MailService.Protocols.MAPI.ServerHandles.FastTransferDownloadContext.GetBytes(Int32 maximumBufferSize, Boolean& done)
   at MailService.Protocols.MAPI.Rops.FastTransferRops.RopFastTransferSourceGetBuffer.Process(FastTransferDownloadContext fastTransfer)
   at MailService.Protocols.MAPI.Rops.FastTransferRops.RopFastTransferSourceGetBuffer.Process(List`1 payloadServerObjectHandleTable)
   at MailService.Protocols.MAPI.RequestTypes.ExecuteRequest.Process()
   at MailService.Protocols.MAPI.MapiProcessor.Process()
0
Even I have issue with an account that doesn't be synced.

It's the only account that I am using to test MAPI.

some folders synced for a couple of days, then stopped syncing.

Unfortunately I don't have any exceptions in the MAPI LOG (it's set on Exception Only and it's completely empty)
0
echoDreamz Replied
Yes, I have that issue too. I left Outlook running overnight with the 1 account working, after a few hours it stopped syncing, restarting the client and it pulled down mail.
1
Robert Simpson Replied
I sent logs and fiddler traces and have been told this will be fixed in an upcoming release.  

At least, my specific issue with MAPI just stopping sync.
0
echoDreamz Replied
Awesome, Robert. Would be cool to get another update pushed out today with this addressed in it. 
0
Matt Petty Replied
Employee Post
Hello,

    We just released a new BETA with some additional MAPI fixes. Specifically, we had some notification changes that should resolve issues with folders (and their accounts) not getting updates. With this release we are recommending people start fresh with their MAPI tests, deleting your Outlook profile, and deleting the MAPI/EWS entry in your connectivity settings in webmail user settings. You can use this guide to help clear out older information,
Matt Petty
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
echoDreamz Replied
This issue does appear resolved in the latest beta. No longer seeing exceptions and both accounts are syncing.
0
It seems to be NOT resolved. Some times Outlook still stops to sync with SM.

Close and re-open Outlook seems to help, but not all the times
0
echoDreamz Replied
I have had Outlook running for 2 days so far, with 3 accounts, I've not yet had any sync issues.
1
Hi Chris, maybe it's an issue with localization. My Outlook is in Italian and some things seems to not work correctly with some conversions (time format and folders names for example)...

I don't know if those are the cause, but that's my hypotesis a the moment
0
Robert Simpson Replied
I'm back to my original sync problem.  The newer sync problem that is fixed with restarting Outlook -- that one's fixed.

But the original issue that's been going on for months, where Outlook just stops syncing one or more folders -- that one is still ongoing.  Right-clicking one of the folders, going to properties, and clearing the offline cache will trigger Outlook to sync again.  That, or deleting the OST file.

Reply to Thread