7429 - Unable to migrate mailbox from an Exchange Server using Exchange Server migration in Webmail --> Connectivity
Problem reported by Gabriele Maoret - SERSIS - 4/10/2020 at 6:43 AM
Resolved
I continue to report the problems I'm finding in my tests with MAPI.

One of the things to do after MAPI is fully functional is to migrate users from Exchange servers. We have many customers who use Exchange in the cloud over OVH.

Now I'm doing test migrations using the SmarterMail Mailbox Migration tool for Microsoft Exchange, but I can't even connect to the Exchange server, SmarterMail keeps reporting this error:

>>>> Unable to connect with the credentials supplied. <<<<

I have verified the credentials several times and tried to switch users.
The connection to the Exchange server works both in the OWA webmail and in Outlook, but the SmarterMail migration tool always gives the same error.

29 Replies

Reply to Thread
0
Larry Duran Replied
Employee Post
Hey Gabriele, are you using the migration that's in the SmarterMail webmail interface?
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
yes
0
Gabriele Maoret - SERSIS Replied
currently it seems there is no working method of transferring a user's complete data (mail + contacts + notes + calendar + activities) from an Exchange server (or similar, eg: Kerio Connect) to SmarterMail, since neither importing PST from Outlook nor Mailbox Migration work


0
Larry Duran Replied
Employee Post
Try using the Exchange option in webmail when doing the migration.  I don't remember the exact code differences between the two but it would be worth a shot.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Larry, it's exactly what I wrote that is NOT FUNCTIONAL.


It doesn't work at all.


0
Larry Duran Replied
Employee Post
Hey Gabriele, I'm going to start a ticket for this issue.  I think we'll probably want a Fiddler trace when trying the migration because I'm curious to understand what client/server requests/responses are going on.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
The Exchange Server are hosted by OVH and I can't access them.
I can give you all (even Desktop Access) of the SamrterMail server, if you need it.
0
Gabriele Maoret - SERSIS Replied
Similar issue even in 7412
0
Gabriele Maoret - SERSIS Replied
...and in 7415 as well

0
Larry Duran Replied
Employee Post
Hey Gabriele, we're continuing to look into this problem.  I think we're running into an auth issue because it's not an Exchange on prem server, which is what our Exchange Migration connects against.  As we work through your folder translation issue we'll also keep investigating this issue as well.  Hopefully we'll have more promising information in the coming future.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Hi Larry!

Yesterday I did an "alternative" test: in the webmail under SETTINGS -> CONNECTIVITY -> MAILBOX MIGRATION instead of using the "Microsoft Exchange" option I used the "SmarterMail" option.

With this option I managed to connect to the OVH Exchchange server that hosts my mail and I managed to do the migration (although I'm not sure that it migrated everything, I still have to check).

If instead I use the "Microsoft Exchange" option it still doesn't work.

For completeness, I am using SM 7417

UPDATE: it seems that not all the mailbox has been migrated.

Exchange OVH reports that the space occupied by my inbox is around 17.2 GB (I also tried to do a exposure from Outlook on PST file and the resulting file is around 19GB), while SmarterMail instead gives the size of the box migrated is approximately 8.7 GB.

From this I deduce that despite the migration process done by SmarterMail SEEMS successful, in reality there is something wrong and that a lot of data is lost on the way.
0
Chris Replied
Our current workaround right now is to migrate from Exchange into SM 15 and then migrate from SM15 to SM 7242. Sucks to hear the migration tool for exchange has not been fixed in the beta.
0
Gabriele Maoret - SERSIS Replied
Today I'm testing Exchange migration with SM 7419 (the server is "Hosted Exchange 2016 by OVH").

The issues are the same as my previous test with previuous SM versions:

  • SETTINGS -> CONNECTIVITY -> MAILBOX MIGRATION --> "Microsoft Exchange": unable to login to the Exchange Server

  • SETTINGS -> CONNECTIVITY -> MAILBOX MIGRATION --> "SmarterMail": the migration works, but not all data has been migrated.
    I can confirm that also by checking the folders content after migration. Example: the Exchange Server inbox has 110039 emails, while the SM inbox only has 42196 emails


This is the log of today migration test:

0
Gabriele Maoret - SERSIS Replied
Today I'm testing Exchange migration with SM 7425 (the server is "Hosted Exchange 2016 by OVH").


The issues are the same as my previous test with previuous SM versions:


  • SETTINGS -> CONNECTIVITY -> MAILBOX MIGRATION --> "Microsoft Exchange": unable to login to the Exchange Server

  • SETTINGS -> CONNECTIVITY -> MAILBOX MIGRATION --> "SmarterMail": the migration starts, I'will report the result later.
    UPDATE: same issue as SM 7419, not all data has been migrated.

this is the LOG:



1
Larry Duran Replied
Employee Post
Hey Gabriele, I haven't been able to do much with this ticket for this week.  However, we might be having another developer look further into this issue for you.  We'll keep you informed on any information we find through that ticket.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
No problem Larry, I know that you all are working hard on that and others things!


0
Gabriele Maoret - SERSIS Replied
New release new tests.

Today I am testing SM 7429 with the same Exchange server and the same test account.

Results: worse than ever. I cannot connect to my Exchange Server with "Exchange" option nor with "SmarterMail" option (I get the same error I've always had with "Exchange").

So I must say that with this version the problem has even worsened !!!!
0
Larry Duran Replied
Employee Post
Hey Gabriele, we haven't addressed any of these issues yet that you're getting with migrations.  We have those tickets open with you but haven't been able to get to them yet.  So these issues will not be resolved until you hear from us in the tickets.  Also, we haven't changed anything with how we connect to Exchange servers with our migrations so this feels like a different issue.  If you can add this information into the ticket you have open that would be best.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Oh, OK! So I will wait for news and stop this tests for now

0
Gabriele Maoret - SERSIS Replied
P.S.: Larry, if you want I can give you access to the Echange Account that I use for testing (it's mine account...)
0
Larry Duran Replied
Employee Post
Hey Gabriele, yeah that would be great.  I'll send you a message in the ticket and you can give me the info there.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Gabriele Maoret - SERSIS Replied
Hi Larry, I sent you the parameters of my Exchange account via e-mail.

Please, I ask you to be very careful because this is my normal work account that I use every day !!!
0
Chris Replied
We are also waiting for this fix, we have a large Exchange 2010 migration coming up soon...
1
Gabriele Maoret - SERSIS Replied
Today I'm testing Exchange migration wit SM 7432.

The migration with the "Exchange" options now starts correctly!

P.S.: i saw that in the changelog: "renamed the username field to email address ".
I think this is wrong, because in on premise installations the username of the Exchange username can be different than the email address, and if you use the "email address" in this field you will get an error.
To me "Username" is better than "email address"
1
Gabriele Maoret - SERSIS Replied
UPDATE: It's seems to work correctly, migration completed.

Now I'm checking the imported data to be sure to find all
0
Gabriele Maoret - SERSIS Replied
The migration seems to have imported almost everything, but this is a problem with the NOTES (some folders are missing) and some emails have different dates from those they had in Exchange.

Example of mail with wrong date. Original in Exchange (date in Italian format, 02 October 2017):





Same mail imported in SM (the date is in the future, 02 october 2020):



I found only this message with this issue, but I don't know if there's other.

maybe this is an isolated case.
0
Gabriele Maoret - SERSIS Replied
Original Notes screen with Outlook connected to Exchange:




Outlook connected to SM (you can easily see that something is wrong and some object are lost/missing or in the wrong place):
0
Andrea Rogers Replied
Employee Post
HI Gabriele, 

You mentioned: "The migration seems to have imported almost everything, but this is a problem with the NOTES (some folders are missing) and some emails have different dates from those they had in Exchange."

Please expect the following resolution in the next BETA build: 
FIXED: When migrating using SmarterMail, Microsoft Exchange, Outlook.com, or Microsoft Office 265 additional folders for notes, tasks, calendars, and contacts are merged in to the default folders.

Regarding the wrong timestamp on your email... can you confirm whether the example you provided is an isolated case, or did you find others that were inaccurate? 

Andrea Rogers
SmarterTools Inc.
877-357-6278

www.smartertools.com

0
Gabriele Maoret - SERSIS Replied
Hi Andrea, yes, the wrong timestamp were an isolated case, I think that there's an error even in the original object

Reply to Thread