Beta [7348] EAS encoding issue for everything that is not UTF-8
Problem reported by Sébastien Riccio - 2/15/2020 at 11:18 AM
Resolved
In previous BETA build, there was in the known issue list, this entry:
- Some characters may not be properly encoded in EAS. 

But on latest build (7348 at the time I'm writing this)  it was removed from known issues. As I thought this might be related to the issue we're having, but I've did some testing again with the latest build and the issues still exists.

Issue is:
Received mails encoded with other charset thant UTF-8 have encoding issue (at least for accents) when they are read from EAS (tested on outlook pc and from mobile devices (iPhone, Android using their built-in mail app) accents). They decode fine with IMAP/EWS and in webmail.

Here is the original mail (encoded in iso-8859-1)




Here are an example screenshot of results: (this is from outlook 2019 on pc)



This is an issue users are complaining about since october 2019. We have opened a ticket about it (XXX-253E0B58-XXXX) and I already created a community thread (december 2019) that never got attention or at least an answer.

Can this issue be reviewed and fixed, at least in the post-MAPI beta releases ?

Thanks,
Sébastien




7 Replies

Reply to Thread
2
Sébastien Riccio Replied
[Ugly topic bump to maybe have some devs/team attention]
1
Sébastien Riccio Replied
[This topic needs some love]
1
Gabriele Maoret - SERSIS Replied
Same here
0
Robert Emmett Replied
Employee Post
Sébastien and Gabriele, are you by chance looking at older EMLs when this is happening for you?  I have just retested sending multiple accented characters via ISO-8859-1 and then syncing via EAS to iOS, Android, and Windows Mail with no issues. You can see from the screenshots that the message was received using iso-8859-1 encoding.  Would you be able to send me a copy of the EML for any messages that are displaying incorrectly?  I should be able to troubleshoot it further with that.


iOS (default mail app):

Android (Samsung default mail app):

Windows Mail:
Robert Emmett
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Sébastien Riccio Replied
Hi Robert,

Can you PM me an e-mail address you're checking with EAS please ?

Thanks
0
Andrea Rogers Replied
Employee Post Marked As Resolution
Hi everyone,

The fix for this issue is being released in the next BETA Build of SmarterMail. Please stay tuned! 

Andrea Rogers
Customer Operations Manager
SmarterTools Inc.
877-357-6278

www.smartertools.com

2
Sébastien Riccio Replied
Hello all,

I have re-tested this issue and can confirm that this is fixed in build 7384. Thanks !

Kind regards

Reply to Thread