2
[17] Calendar error message
Problem reported by Martin Schaible - 1/21/2020 at 5:30 AM
Resolved
If i click on "All appointments" i get the message "Object reference is not set to an instance of an object". No more appointments are visible then forever. Really annoying. A restart of the SmarterMail Service didn't help.

A user gets also a warning, that he has no access to a certain calendar, which is simply not true.

I think, that the mass of data is the reason.


Any idea?

Thanks

5 Replies

Reply to Thread
0
Martin Schaible Replied
I think, this is a serious bug now. The users are really upset now.
0
Emily Ward Replied
Employee Post
Hi Martin,

I'm sorry you're having this issue.  Since your license has curreng Maintenance and Support I've submitted this as a support ticket on your behalf.  You should get a response from a support agent shortly.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Sébastien Riccio Replied
Hello Martin,

Not sure if this is the same issue, but last time this happened I've discovered that the default calendar of the user disappeared from the user's folder.json:

Here is what I sent to ST support after finding out about it:

As our customer was stressing about this, I took the time to understand how folders.json and the different folder-xxxxxx.json works and finally discovered the problem.

I did a difference check of the users folders.json file from the backup before 7142 update and after the update.

in folders.json from backup before the update contains this entry:

{
"guid": "8c7dbd0436b54aa598b000116f7e27c3",
"id": 530043,
"type": 4,
"change_number": 2905639223488,
"display_name": "My Calendar",
"color": "#559CD4",
"is_primary_for_type": true,
"contents_modified_utc": "2019-05-29T03:42:17.0165413Z",
"extra_properties": []
},

However the user folders.json from after the update, this entry is gone!
I added it back to the user current folders.json and now the calendar is working again.

Now we hope that there isn't other users with the same problem. Do you have by any chance a tool to check the user against this kind of integrity problems ?


So maybe the first step to see if this is the same issue, you could check the user folder.json file to see if there is an entry named ""display_name": "My Calendar","

If this is missing, it's probably the same issue. I fixed it by adding back the entry from a backup of the file and calendar started working again.

edit: if you have to restore the entry, be sure to take it from a backup of the user folder.json file, I guess the ID's are important so you can not use some random values here.

edit2: For ST team, if you want to check the ticket I had opened for this, it's the one containing 2550C0C2 .

Sébastien Riccio
System & Network Admin

1
Martin Schaible Replied
Marked As Resolution
This issue was solved by SmarterTools by delivering an updated version of SmarterMail.

Thanks to SmarterTools for the fast and friendly support, thumbs up !

1
Emily Ward Replied
Employee Post
Martin,

I'm glad to hear support was able to get this fixed for you.  I'm changing the status of this post as Resolved.  The fix will be in the next release of SmarterMail.  If anyone else runs into this issue and we have not released the fix yet, please reach out to us via email or a support ticket for the fix.
Emily Ward
Customer Relations and Partner Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread