MAPI doesnt seem to properly display embedded images
Problem reported by echoDreamz - 1/13/2020 at 2:44 AM
Resolved

When using IMAP, EAS, EWS on eMClient, this email shows the images properly, however MAPI (Outlook) doesnt show the images at all. Emails that use HTTP-linked images load fine though.

11 Replies

Reply to Thread
0
Alex Clarke Replied
We're seeing the same with the latest version of Outlook.

0
Larry Duran Replied
Employee Post
Hey all, we recently fixed an issue with embedded images and MAPI on the latest release but maybe we missed something.  Can you two private message me a copy of the raw email text and I'll be able to triage the issue for you.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Thomas Lange Replied
Hi Larry,

concerning embedded images/attachments like company-logos embedded as part of the signature there are some things better and being now displayed correctly in build 7314 - but not all, and at a quick first check these attachments are showing up at attachments additionally.

I will take some screenshots where hopefully you can see some difference/issues - and I will attach .eml files for reproducing. I will try to show you MAPI, EWS(eMClient). It will take a few hours but I suppose later/end of this day I have some examples for testing/fixing ready for you and send to you as private message.

Thomas
0
Alex Clarke Replied
Thanks Larry. Raw content has been sent to you.
1
Thomas Lange Replied
I sent two private messages to Larry, each with .eml-file and sample screenshots in different protocols/clients and webmail.

So I hope SmarterTools will figure this out so that they will be able to provide a fix or what we can do to see better/correct results in email-text/body.
0
Larry Duran Replied
Employee Post
Hey Alex and Thomas.  I did receive the raw content emails.  I'll run some tests on my side and see what we can figure out.  I'll let you know what I find.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Larry Duran Replied
Employee Post
Ok all thanks for submitting those emails over to me.  We were able to get some fixes in place and they will be in the next build.  After our next release, if you're still seeing attachment issues then let us know.  However, things should be much better.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Alex Clarke Replied
Great news!

When's the next build going to be released?
0
Larry Duran Replied
Employee Post
I'm sure we'll release something this week.  You will probably have to re-add the Outlook profile to capture the changes for attachments.
Larry Duran
Software Developer
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Alex Clarke Replied
Thanks for confirming Larry.
0
Thomas Lange Replied
Marked As Resolution
in MAPI build 7320: MAPI-protocol and embedded/inline images are much better now. Good work! Thank you.


and yes: deleting and re-adding outlook profile/account was neccessary

Reply to Thread