Has anyone seen delays in receiving emails from a forwarded account?
Question asked by Patrick Mattson - 8/28/2019 at 10:13 AM
Answered
Currently running 7153 (Aug 2, 2019)
Customer has a generic account they can log into named office. Email here comes in quickly. This email forwards to 5 or 6 other emails within the same domain. During this forwarding emails can take exactly 5 minutes for each of the recipients of the forwarding to receive the forwarded email.

individually there is no delay only during the forwarding process.

Anyone else experience this or have insight.

6 Replies

Reply to Thread
0
Kyle Kerst Replied
Employee Post Marked As Answer
Patrick, these delays are a direct result of the looping issue I just followed up with you on in the other thread. Once you've deployed the minor update (http://www.smartertools.com/downloads/SmarterMail/CustomBuilds/100.0.7172.16219/SmarterMail_7172.exe ), please navigate to Settings>General>Spool and adjust your retry intervals like so: 

1, 1, 5, 5, 15, 30, 30, 30, 30, 60, 90, 120, 240, 480, 960, 1440, 2880

The forwarded copies of these messages are always sent on a second attempt (separate message sessions) and so the retry intervals above should provide a retry attempt for any given scenario and allow the message to forward within 60 seconds. 


Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Patrick Mattson Replied
Thank you for a quick response I am trying that setting now.
0
Kyle Kerst Replied
Employee Post
Sounds good Patrick, you'll want to get that custom build installed as well to fully resolve the issue.
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Sébastien Riccio Replied
Hi Kyle,

Since this behavior changed and the forwarding to external adresses is delayed and depends on retry intervals, I would suggest that the documentation is updated about it and that administrators are aware that there is now a minimum of 1 minute delay for external forwarding. (it still makes no sense to me, but as it looks lile it's going to stay like this, at least the doc should mention it).

Kind regards.
1
Thomas Lange Replied
Sebastien, I agree - helpfiles/documentation need an update!
I myself checked the help as we had to deal with "looping / delivery failures" and number of messages in Spool+Waiting for delivery were heavily increasing, there I found the 4 attempts (15min, 30min, 60min, 90min).

With custom build 7172 this is much better, and we adjusted the retry-intervals as suggested by Kyle,
but this really needs an update at least concerning the delay and delivering in second try/retry...
I do not know any mailserver where we had to configure such "strange/untypical" retry-settings for delivery!

Because "new default values" will probably only affect "new system/initial-installations" it would be good to have kind of checks and one-time-warnings about settings that differ from new/suggested "default" values.
0
Sébastien Riccio Replied
True Thomas,

We also had to deal with the loops and these strange forwarding delays at same time and seeing sometimes up to 10 minutes delay for external forwarding. As you did we applied Kyle suggested retries values and now forwarding to external mailboxes are delayed "only" by 1 minute (according to the first value of the retries list). Still confused though. I administer other mail servers based on postfix, or exim, even the good old sendmail. I never seen any need to delay external forwarding.. they are processed straight away....


Reply to Thread