Multiple (Two) URL's (logins) in One Smartre Mail Installation
Question asked by Shoaib Nawaz - 7/28/2019 at 2:58 AM
Answered
Hi,
We are running SmarterMail v 15.7. Enterprise
All our domains users are login with webmail.domain.com. We also used same URL for incoming/outgoing server. We install the 3rd party certificate with port mapping. 
My question:
Can I use another URL in IIS like hostdns.domain.com. for web login and outlook configuration. 
I think, I need to change the port for this URL as port 443 is using for webmail.domain.com
Someone please help me and if you have any KB article or step by step instruction than please share with me.
SM running on windows 16. 

4 Replies

Reply to Thread
1
Jade D Replied
Marked As Answer
The changes depend on the version of Windows that you are running, if pre Windows Server 2012 R2 then you would add the SSL certificate to the existing Smartermail website, but use a new IP address for the binding of hostdns.domain.com 

From Windows Server 2012 and up, Windows supports SNI

Make sure your certificates are stored within the webhosting store and not personal store.
Edit your IIS bindings and make sure that all certificates are set to "Require Server Name Indication" on the same IP address using the correct host headers.

As you can see below, we use multiple ssl's on the same website, using the same IP
0
Shoaib Nawaz Replied
Hi Jade,
Thanks for the detail reply. We are running SM on Windows server 2016. 
Let me try to configure 2nd URL as per your suggestion and share my experience here.  
0
Shoaib Nawaz Replied
Hi Jade,

Really appreciate your answer. I follow your instruction and everything is working fine. Thanks Again for your help. 
0
Shoaib Nawaz Replied
Hi, 

I have another question, When i am using single URL, i follow this article https://portal.smartertools.com/kb/a3195/configure-ssl-tls-to-secure-smartermail.aspx  and configure the port 465/993/995 with SSL setting.
I follow the same URL and export the certificate via Web Hosting instead Personal. 
Outlook is not connected with SSL, default port (25) configuration is working fine.
How to resolve this issue? I need to import the certificate in Personal and than Export it. Please confirm 

Reply to Thread