DKIM is not Optimal
Question asked by Michael Luer - 5/24/2019 at 9:57 PM
Answered
It passes the test with caveat saying " DKIM is not Optimal"  It seems to be causing a few failures in delivery. 

TestResult
DKIM Syntax CheckThe record is not optimal More Info
DNS Record PublishedDNS Record found
DKIM Record PublishedDKIM Record found
DKIM Public Key CheckPublic key is present

What is not optimal, I used the dkim generator for the domain.  I also used 2048.  not sure whats going on. 

5 Replies

Reply to Thread
0
Michael Luer Replied
v
VersionThe DKIM record version.Missing from public DNS record

I only put in what was generated.. what is it missing ?
1
Michael Luer Replied
Marked As Answer
ok figured it out.  I had to add v=DKIM1;  to the front of the key to be compliant now.  the dkim generated by smartermail didn't generate what version of the record it was just they key.

so once I put the v=DKIM1; in front of the p=jflsjfl jsdklfj as;fj adsklfj kadslfj klasdfj kladalks  Key

v=DKIM1; p=jskldfjasjkflsdjflsdjfklsdjfklsdjfkfjsdkljfsdYOURKEY   just like that. 

It stopped complaining about not being optimal. 
0
Pascale Guilbault Replied
YESSSS. Thank you, that work for me to!!
0
Scarab Replied
Michael,

You might also want to add the k=rsa; flag as well, so that your entire key reads in DNS as:

"v=DKIM1; k=rsa; p=yourDKIMkeyfromsmartermail"
0
Michael Muller Replied
To compound the issue, that pop-window shows [random-key]._domainKey.[domain].com  WITHOUT the trailing period, without which the world will append the domain name, again.

If you're going to include the domain name in the DKIM in your DNS, it needs to be followed by a period, or the assumption is it's short-hand.

[random-key]._domainKey   (short hand, assumes domain name will be appended)

[random-key]._domainKey.[domain].com.   (long-hand, complete DKIM declaration, note the trailing period)
---
Montague WebWorks
Powered by RocketFusion

Reply to Thread