[BUG] Mailing List #UnsubscribeLink# Uses http:// instead of https://
Problem reported by Shaun Peet - May 13 at 6:49 PM
Being Fixed
We have our server setup to force all traffic under HTTPS but the default UnsubscribeLink for a mailing list uses http:// and not https:// which results in a 404 not found for users who click the link in the message.

A temporary work-around is that for each individual list the domain admin can set the Webmail URL in the List Settings.  However, when that field is blank it's obviously pulling the correct webmail URL from somewhere, just not the HTTPS part of the address.


11 Replies

Reply to Thread
0
Rod Lasky Replied
Employee Post
Hi Shaun.  I just tried this on our production server, and the #UnsubscribeLink# did redirect to HTTPS.  What version are you currently running?
Rod Lasky
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Shaun Peet Replied
100.0.7068

I believe this started happening with that version since we've gotten several support tickets about this same issue that started relatively recently, and most people in the support tickets referenced something along the lines of "it used to work before".


0
Kyle Kerst Replied
Employee Post
This may be related to the hostname field in the domain configuration, the hostname option under Settings>General, or the hostname configuration found associated with the server or domain IP address under Settings>Bindings>IP Addresses>IP Address. Can you check those out as well?
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
0
Shaun Peet Replied
We've got about 500 domains on the server.  One of the domains having the issue is lasallesabres.com and in their domain settings the hostname is set to mail.lasallesabres.com.  The domain default for hostname are mail.%domain% so new domains are created as such.  We also control the DNS settings for every domain and have CNAMEs setup as (for example) mail.lasallesabres.com -> mail.mbsportsweb.ca.

In Settings -> Bindings -> IP Addresses -> IP Address, for the IP address in use both the hostname and the description are set to mail.mbsportsweb.ca.

None of these hostname settings specify http or https.  However, in the domain settings for lasallesabres.com in the security section, "Force all traffic over HTTPS" is enabled for this (and every) domain on our server.

0
Kyle Kerst Replied
Employee Post
Thanks Shaun, based on your findings I think you may want to first try updating to the latest minor (there were some mailing list fixes there) and if this is still an issue; submit a support ticket so we can get the details and report it to development. Thanks, and have a great day!
Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Shaun Peet Replied
I thought 7068 was the latest minor?
0
Kyle Kerst Replied
Employee Post
It is, if you're already on that I would recommend submitting a support ticket so we can take a closer look at this. I'll see if I can get this reproduced in our environments now as well. 

EDIT: Shaun, while attempting to test this I noticed there is a Webmail URL field you can configure within the mailing list's settings per the attached screenshot. Can I have you confirm the address is not set incorrectly here?

Kyle Kerst
Technical Support Specialist
SmarterTools Inc.
(877) 357-6278
www.smartertools.com
1
Shaun Peet Replied
Hi Kyle,

Please re-read my first post.  I already mentioned that we've noticed the property in the list settings itself where it's possible to override the auto-generated HTTP link by specifying the HTTPS version.

The issue here is that when that property is left blank that it auto-generates the HTTP link, and that it appears this is a bug that was introduced in a recent version since it was not happening before.

So yes, I can confirm that the "webmail URL" setting on the lists we're seeing this issue is blank.

Shaun

0
Shaun Peet Replied
Bumping this up.  Version 7118 is our current version and the problem still exists.

Going to install version 7153 today and see if it's resolved but I doubt it given that it's not mentioned in the release notes.

0
Shaun Peet Replied
Updated to version 7153 and the problem still exists.  To recap..

In Settings -> General the only thing that mentioned the Webmail URL is in the File Storage section, and that is set to be https://mail.mbsportsweb.ca/.  There's other settings which define the hostname (Settings -> General -> Server Info, Settings -> Bindings) but those never specify http: or https:

In the Manage -> [domain] page, in the Security section, "Force all traffic over HTTPS" is set to true, and the hostname there is also correct (and does not specify either http: or https).  In the Mailing Lists section for the domain there's nothing in there about the Webmail URL (at the domain level).

Using the above, the #UnsubscribeLink# auto-generates a link back to our mail server using http: which creates a 404 error when the "Webmail URL" setting for a given mailing list is blank.  So, it properly generates the entire URL somehow, but the only issue is that it's not the https: version.

Lastly, setting the "Webmail URL" to https://mail.mbsportsweb.ca for an individual mailing list does indeed fix the problem, however, since our users would have to do that for *every* mailing list they have, that's not a very user-friendly work-around.

What's our next steps?

0
Ben Gilstrap Replied
Employee Post
Shaun,

So that we can better track this issue through to resolution, I've gone ahead and created a support ticket for you.  This will also help to expedite getting a fix in place.
Ben Gilstrap
Regional Sales Executive
SmarterTools Inc.
(877) 357-6278
www.smartertools.com

Reply to Thread